Support » Plugin: Contact Form 7 » Reply-to doesn’t work anymore in Gmail

  • smallstar67

    (@smallstar67)


    A few days ago the reply-to in emails from our contact form stopped putting the customers email address in the reply field and instead started placing our email address there, making our replies get sent to ourselves.

    Any hope of the fix for this?

Viewing 15 replies - 31 through 45 (of 46 total)
  • And I’m using the same email account to send as, when using my phone and when using the desktop (where it doesn’t work), so the issue is not what you set as ‘send as’ in your gmail because it works from my phone with that same account and email address.

    It worked fine for over 2 years for me, I didn’t change a thing then it just stopped working recently on my desktop.

    I had this problem to.. changing the from adress in cf7 to ‘noreply@mydomain.com’ works. However now i still have the problem that Woocommerce also sends the new order email with both ‘from’ as ‘to’ adresss being info@mydomain.com.

    I have tried changing the ‘to adress’ to test123@mydomain.nl and forwarding that in Direct Admin to info@mydomain.com again. But that will (logically) not solve the problem.. Since WC still uses the admin email (info@mydomain.com) as from adress.

    Als changing the standard reply adress in gmail settings to another alias for example cheese@mydomain.com does not work.

    So definitely a Gmail problem and not a CF7 problem. I know Gmail is trying to get users who uses alias for work to upgrade to a Google business account by downgrading the functions in Gmail itself. This is probably another thing to get more paid users?

    Edit: how simple a sollution can be. In WC email settings just change the from adress to for example orders@mydomain.com

    • This reply was modified 3 months, 3 weeks ago by  Bakkie.

    Hi @eeuweb,

    Woocommerce sending the “new order” email (the one for the admin) to the admin email address set in WordPress Settings > General, is the standard and expected behavior. Unless you use a plugin like wp mail smtp or so to change it.
    (please someone correct me if I’m wrong).

    I am not sure to understand why this is a problem for you? And also how is this related to the reply-to gmail issue? Thanks!

    This has nothing to do with woo commerce. it’s an Gmail change that doesn’t recognize the reply to field any longer. Putting a different email, or added characters like “+” doesn’t work.

    This is a change in how Google Gmail looks at the reply to address. Google has to fix it. All the fixes I’ve seen on this thread do not work for us.

    That’s the conclusion I came to as well, wasted so much time on this, even spoke to a few people at Google who aren’t even aware of the problem it seems, let alone admit to it. Forget about the extra step involved in actually fixing it for us. Obviously too hard for them to look after their paying customers. Too big to care it seems. They could at least look into it for us when we tell them, instead we have to do all the running around trying to find who is at fault. Crazy world we live in where the giant companies of this world sell us an empty box then we have to fill it with a product and maintain it, fault find it and keep it working for them to keep making money from it. While they use this money to develop and create ‘updates’ that wreak havoc worldwide and costs businesses money and time. Then ignore us when we question their product.

    I’ve been told by Google to contact the plugin author as it is not their problem!
    Which plugin author?
    WpForms?
    ContactForm7?
    Gravity?

    The problem is obviously Gmail for sure. Probably a new security thing we all just have to live with. Perhaps they have no intention of fixing it, perhaps it was done deliberately.
    Months go by and no-one involved answers these questions while 1000’s of us wait and try to get on with life.

    Hey, I just discovered that it now works good again in Gsuite mail at our account.
    Maybe Google fixed it… and will roll it out everywhere?

    Hope for you all…

    … stopped working again ;-(

    This has been a problem for about 2 months for me. The “Reply To” parameter is ignored by gmail. I am using sendgrid as well, but do not believe it is their issue.

    freezer33

    (@freezer33)

    THought I was going mad. Switched to using mac mail as it recognises reply to protocol. Also, no issues with outlook either on desktop or phone. Hopefully Google will sort this.

    ausworkshop

    (@ausworkshop)

    It’s got even worse…. Now when I right click to copy the customer’s email from my form (so I can paste it) another window opens up as a compose box. It seems Google is assuming I want to send that person a whole new email rather than simply replying and keeping it all in the same conversation thread (avoid confusion).

    So just when I got used to this extra step of copy and paste I now have an extra step of having to close this annoying pop-up window in between scrolling up and down from the original form entry to the reply I have started and am pasting into.

    Ridiculous waste of time! So annoying when something I do every day just gets more and more complicated because someone at Google decides to experiment with a new way of doing things then try to force it upon us as the right way.

    Does anyone who actually uses Gmail test these things first before implementing changes upon us all? Or is it just some crazy idea they come up with in a quick meeting while on their way to a long lunch?

    Let’s add extra steps to everyone’s lives and complicate it further for them.
    Great idea!

    Not working for me either.
    I’m using “noreply@mydomain.com” in the “from”.
    Additional headers:

    Reply-To: [your-email]
    Reply-From: info@mydomain.com

    Mine is working again! Google must have changed something because I left everything as it was and now it’s working again so hang in there, it might come good for you too one day. Just wish we knew what was going on.

    koekie1975

    (@koekie1975)

    Same problems here, WP/CF7/WP Mail SMTP. I fixed this by doing the following:

    Step 1: Make the from and to field different addresses. I used no-reply@domain.com
    Step 2: After that I cleared the field “Reply-To Email Address” in WP Mail SMTP.
    Step 3: Then I added my new address to “Don’t Replace From Field” in the advanced settings of WP Mail SMTP.

    smallstar67

    (@smallstar67)

    actually, you could do nothing as Google has fixed this issue on their end.

Viewing 15 replies - 31 through 45 (of 46 total)
  • You must be logged in to reply to this topic.