Support » Plugin: Contact Form 7 » Reply-to doesn’t work anymore in Gmail

  • A few days ago the reply-to in emails from our contact form stopped putting the customers email address in the reply field and instead started placing our email address there, making our replies get sent to ourselves.

    Any hope of the fix for this?

Viewing 15 replies - 16 through 30 (of 46 total)
  • Still not working for me…
    Hope someone will find a sustainable solution.

    @jaggana it’s pretty clear this is a gmail issue as it is affecting lots of users as shown on the gmail product forums thread I linked earlier. There are a couple of workarounds in the meantime listed in this thread while everyone waits to see if Google will fix this problem with their web client.

    I’ve been having this problem on a handful of sites recently. The work around @soulshakepower worked out is working for me.

    The work around of changing the domain name of the sender’s email doesn’t work for me. Makes no change in how Gmail reads the header.

    The work around of changing the domain name of the sender’s email did work for me.

    However, all the contact forms I receive are now on the top of each other instead of being displayed separately.

    Kudos to @soulshakepower for sharing this tip, it works!

    The kicker is I faced this issue using Gravity Forms (along with new Gmail) and changing it to no-reply@mydomain.com did the trick. So, this is more of a Gmail specific issue thank can be remedied by changing your WordPress notification email settings, whether you use CF7, Gravity Forms or any other plugin. Cheers!

    Well I’d rather not mess with it for now, hopefully it will sort itself out. The thing is, I think I remember being told to make my reply-to the same email I use as my alias. basically had to use the same email for everything in my settings and have it all set to work through the SMTP plugin just to get Gmail working through the security filtres from my website server and through theirs etc (which I pay for the privilege each month for my business). It was a real hassle to get working after it stopped last time so I’m reluctant to fiddle or I might miss out on emails from my contact form all together, either that or my customers will never get my replies and I’ll never know.

    I have enough trouble getting my invoices to go through to peoples emails these days.
    It takes way too much of my time all this stuff. While my customers wait… Too many security settings to work through and fiddle with just to do basic online business, tasks which used to be easy 10 years ago are now unreliable and costing us time/money daily. Thanks Google!

    Howdy,

    Just wanted to share that I’ve successfully implemented a work-around (posted here:https://stackoverflow.com/questions/2421234/gmail-appearing-to-ignore-reply-to ) for this issue on my WP site using CF7 and checking/replying via Gmail:

    In short, add a “+” symbol to your reply-to email address in your “From” field (NOT your additional header/reply-to field)

    CF7 Exa:
    To: example@whatever.com
    From: [your-name] <example+@example.com>
    Additional Headers: Reply-To: [your-email]

    I popped it over via Gmail, clicked reply and the correct reply address appeared in the reply email.

    Cheers,
    //D

    smallstar67

    (@smallstar67)

    Adding the + before the @ didn’t do anything but break the form for me. The contact form puts up an error message and nothing is sent out.

    doronyosha

    (@doronyosha)

    Hello
    Im also facing this problem, I will be happy to hear if anyone succeed to solve it.
    My site: https://beetravel.co.il/en/
    Thanks
    Doron

    jenkisan

    (@jenkisan)

    Found super easy solution:

    in cf7 the from and to address canot be the same. If they are different then gmail uses the reply-to field.

    This measn however, that the domain should be the same but the user differen.

    So for exmaple

    to: info@test.com
    from: web@test.com
    reply-to: [your-email]

    Works fine this way.

    smallstar67

    (@smallstar67)

    I would have to respectfully disagree. That is the very first thing just about everyone tried.

    jenkisan

    (@jenkisan)

    How can I prove it solved the problem for me? Let me know and I’ll post. I’ve been having this problem for about 3 days since I setup the contact forms. I looked everywhere!! (Even here, which by the way none of the suggestions here say to try this, or perhaps I did not understand to try this way). I finally came across a post on the gogoel support forum and this was the suggestion. Tried it and it worked. Maybe the problem I was having was different then.Anyway, I’m here to share. If others want to try go ahead. I noticed also that in this thread some suggestions worked for some and not for others so maybe we don’t actually all have the exact same problem. GL

    PS sorry there is one more caveat, the from: email cannot be send as email setup in gmail.

    • This reply was modified 5 months ago by  jenkisan.

    For me, the solution was to use a “From” address on my web site domain that doesn’t have to be real, e.g. if I’m http://www.domain.com I used noreply@domain.com even though that email address is not a real account. This satisfies Contact Form 7, so I can send “To” realcontact@domain.com which is a GMail alias, and the Reply To header value of the form sender’s email address then works:

    Reply-To: [your-email]

    Cheers

    Thanks, Do you mean the admin email in WP? …I tried that, didn’t work, so I set it all back to the way it was until I find out for sure what is going on.

    I have noticed that if I reply to my form using Gmail on my phone (Android) it still works and has the correct email in the To field.

    So it only started happening for me on the desktop (where I need it most).
    I’m still thinking it’s a Google thing, only started happening recently, WPForms is doing the same thing now as is Contactform7. The one thing in common is they all come in to my Gmail Inbox.

    I’ve tried various things to fix.
    I’ve now removed Contact form 7 and just using WPForms but the same issue remains.
    Only on desktop, perhaps it’s a chrome thing?
    Is everyone else who this is happening to using GSuite?

    I don’t like to go messing with all my setting spending hours trying to fix until we at least find out what caused it.
    This was all working fine.
    Somebody changed something with an update and now we spend hours looking in all directions without knowing what caused it in the first place.
    SOMETHING CHANGED!
    I spoke to Google last week and they say the issue must be with the plugin and to contact the author.
    Both plugins are doing it and only if using a desktop (Chrome browser) to do my emails.

    Is the issue with Chrome?
    GSuite?
    Who knows?
    Someone must have the answer to this at least.
    Then we can work out a decent fix for everyone.

Viewing 15 replies - 16 through 30 (of 46 total)
  • You must be logged in to reply to this topic.