Support » Plugin: Comments - wpDiscuz » REply Notification not working

Viewing 3 replies - 1 through 3 (of 3 total)
  • Also tried it on another website – it is sending a confirmation email to subscribe to the comments – this seems suprising given that we have ticked :

    Disable subscription confirmation for guests

    There is a major problem with this plugin.

    It looks like the plugin’s contact form is forging the From: header on outgoing emails (which means that the form creates the email as though it was sent by the email address entered by the user) as opposed to using the built in account.

    This runs into issues with email providers like Yahoo, Hotmail, and AOL accounts.

    The other issue is some hosting providers have such domains listed in their system’s mail filter as common targets for abuse. Because of the way the form sends the emails, any message from an @aol.com, @yahoo.com, or @hotmail.com email address will be discarded by the system filter when it doesn’t come from the underlying domain’s account.

    So you’ll probably have to either modify the form’s code (and continue to do so every time there’s an update), or ditch the plugin.

    Unless the authors provide an option to set the “From” address such as “noreply@yourdomain.com”.

    Plugin Author gVectors Team

    (@gvectors-team)

    Hi FireMyst,
    Please check the wpDiscuz functions and you’ll see that there is no “major problem with this plugin”. wpDiscuz uses WP installation admin email and admins may use @yahoo.com or other above mentioned domains but not website domain. This is the problem.

    1. Do you know that WordPress uses “wordpress@yourdomain.com” email as a from address? So the default From email doesn’t look good for website owners.

    2. wpDiscuz uses the email admin set on installation as the From Email. The From email is the email set by you in Dashboard > Settings > General admin page. So the FROM email changing option already exists and you just need to insert email address with your domain, such as admin@yourdomain.com. That’s it. Here is the wpDiscuz function:
     

    3. In case you don’t want to use WordPress installation admin email you can use WordPress hook and put this code in theme’s functions.php file to change it (this has been provided in dozens of our support questions):
    https://gvectors.com/forum/how-to-and-troubleshooting/emails-are-coming-from-wordpress-com-i-dont-want-that-where-do-i-change-it/#post-1331

    function res_fromemail($email) {
    $wpfrom = 'example@example.com'; return $wpfrom;
    }
    function res_fromname($email){
    $wpfrom = get_option('blogname');return $wpfrom;
    }
    add_filter('wp_mail_from', 'res_fromemail');
    add_filter('wp_mail_from_name', 'res_fromname');

    4. So there is already two ways (#2 and #3) to change your FROM email. in case you don’t want to use admin email and don’t want to put the code in functions.php we’ll add an option in future versions to add an FROM email address for wpDiscuz emails.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘REply Notification not working’ is closed to new replies.