Support » Plugin: Easy WP SMTP » Reply Address is wrong

  • Reply-To Email Address is empty.

    SMTP Host is set to: smtp.gmail.com

    Unfortunately, all emails arrive with the from email showing as “From Email Address”, instead of the actual sender’s email address.

    The “From Email Address” is info@beermoneybooks.com which is handled via Google Suite.

    Thanks for helping to resolve this issue.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, please check the following documentation. Let me know if this helps you.

    Thank you

    Hi,

    No, that documentation didn’t actually help with the problem.

    I guess I could try using my local server as the SMTP server instead of Google/GMAIL server if you think that might make a difference?

    Thanks.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    I guess I could try using my local server as the SMTP server instead of Google/GMAIL server if you think that might make a difference?

    Yes that would definitely work better for you.

    Let me know how you go.

    Thank you

    We changed to using our AWS servers for email and still have the same problem.

    We get an email sent to our gmail account (info@beermoneybooks.com) which now shows the proper sender’s email address.

    However, when we hit reply in gmail the “to address” gets changed to info@beermoneybooks.com instead of the email address entered by the person that submitted the contact form submission.

    How do we fix things so when reply is clicked in email, the actual email submitted with the contact form shows in the to field so the email is properly addressed?

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, who is your host? What contact form plugin are you using?

    Thank you

    Hosted on AWS.

    Contact form via Divi Theme.

    I used your WP Easy SMTP because of this article recommendation:

    https://divitheme.net/divi-contact-form-not-working/

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, your best option is to contact divitheme developers. Let them know that their instructions is not working for you.

    Let me know what they say.

    Thank you

    beermoneybooks

    (@beermoneybooks)

    It’s actually a Gmail thing, not necessarily a website or Divi issue. When someone fills out the contact form on my website, it submits the message to my web server and WordPress uses php to send you an email containing all the information the person put into the form. When this email is sent to me, it is technically sent from my website, not the person that filled out the form.

    So, the “from” address will always be my email address and if I just hit “reply” like I would in a normal email, it will reply to the “sender”, which is technically me. If I don’t want to use a third party customer support service like ZenDesk or Draft, there is no way around this since the contact form email will always be coming from my server.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, unfortunately I don’t use my Gmail account via the browser to reply to my e-mail. Check the following forum post. The person in the forum post had a similar issue to you. Let me know if this helps you in any way.

    Kind regards

    beermoneybooks

    (@beermoneybooks)

    Unfortunately, it looks like Gmail has changed since that forum post and the “treat as alias” setting has been removed?

    Plugin Support mbrsolution

    (@mbrsolution)

    You might be right, it might be a Gmail related issue and not our plugin? I have read in another forum post for Contact Form 7 about the same or a similar issue to yours.

    Regards

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi,

    Unfortunately, it looks like Gmail has changed since that forum post and the “treat as alias” setting has been removed?

    I just checked my Gmail account ant those settings are still there. Go to Settings -> Accounts and Import -> Send mail as:, then click on Add another email address link. Then follow the on screen instructions.

    Let me know if this helps you.

    Kind regards

    • This reply was modified 5 months ago by  mbrsolution.
    beermoneybooks

    (@beermoneybooks)

    Yes, I saw that, but I don’t know how that will help.

    This is what that screen looks like for me, so what email do you suggest adding or settings change?

    https://www.dropbox.com/s/9sj8p3u8v8on9np/Screen%20Shot%202019-02-17%20at%209.44.36%20PM.png?dl=0

    Thanks.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, unfortunately I have never set this up myself with Gmail. I don’t use Gmail, Hotmail or Yahoo. I only use my sever e-mail addresses which never causes any issues. The following comment is what our plugin developers recommend.

    The best option is to use your own server’s SMTP (the details provided by your hosting provider). You get the best result when you use your own site’s SMTP details.

    However, if you wanted you can use the common SMTP servers offered by Gmail, Yahoo or Hotmail. These are not very reliable though.

    Apparently the CF7 link I shared above, also talk about the same problem as yourself I believe. So if you can find out from that support thread a solution, I would be keen to know myself. If you do find a solution, you might also like to share it here for others to know.

    Kind regards

    Plugin Support mbrsolution

    (@mbrsolution)

    Also if you don’t enable Treat as an alias you will run into the following issue, described in one of the links I shared above.

    If you use Gmail’s Send mail as feature to send messages on behalf of another email account, you may encounter the following issues: (…) If you receive a message from a Send mail as address and you click Reply, the To: field is incorrectly populated with your primary address. (…) These issues occur because Gmail treats your Send mail as address as an alias of your primary address. You can change this behavior in your mail settings by deselecting Treat as an alias.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.