WordPress.org

Support

Support » Plugins and Hacks » [Resolved] "Replies only" subscriptions receiving "All" comments

[Resolved] "Replies only" subscriptions receiving "All" comments

  • Raam Dev
    Participant

    @raamdev

    For some reason all my readers that have selected “Replies only” when commenting are getting notifications for all comments made to the post, not just replies to their comments.

    I have confirmed that their status shows up as R and not Y inside Manage Subscriptions, yet they still receive an email for any comment posted.

    Any thoughts on how I can go about troubleshooting this? Is anyone else experiencing this?

    http://wordpress.org/extend/plugins/subscribe-to-comments-reloaded/

Viewing 15 replies - 1 through 15 (of 20 total)
  • I have the same problem.

    extremecarver
    Participant

    @extremecarver

    I don’t have that problem (only not very nice that one need to change the sourcecode to have R instead of Y as default status).

    Raam Dev
    Participant

    @raamdev

    I’ve created a fix for the broken Subscribe to Replies Only feature. You can download my fixed version here:

    https://github.com/raamdev/subscribe-to-comments-reloaded/archive/master.zip

    You can also follow development on my ‘raamdev’ branch of this plugin here: https://github.com/raamdev/subscribe-to-comments-reloaded/tree/raamdev

    Great Thanx! Need to try your fix.

    Raam Dev
    Participant

    @raamdev

    Please do! And please let me know if you have any trouble with it. I’ve tested the changes and it seems to be working fine, but please do let me know if you discover any problems.

    oldmankit
    Participant

    @oldmankit

    Raam’s fix is working perfectly.

    extremecarver
    Participant

    @extremecarver

    I sometimes have that problem too now… Only very seldom users are affected though. Will try the patched version too…
    (too bad, IMHO this functionality should be wordpress core function, not some plugin that has bogus working if unpatched)..,

    extremecarver
    Participant

    @extremecarver

    okay, 2 of my users got bugged by this problem too. After enabling Raam’s version since 2 days, they haven’t been “spammed” anymore. Let’s hope it stays this way…. (also the rewordings and default to R instead of Y is very wellcome – even though I decided to remove Y alltogether as it caused confusion).

    BeautyPirate
    Member

    @beautypirate

    When I install the fix, the admin pages gives me a 404 error on the front page? What would cause THAT? o.O

    I donĀ“t have the original plugin installed before I installed the fix because it said it is a fixed version, not a fix. Is that correct?

    dish56
    Member

    @dish56

    I’m having the same issue as BeautyPirate. I have removed the original version and installed the fix. But now I just get a 404 page. (I did this yesterday, and can’t remember if the 404 came up when I tried to activate the revised plugin, or when I tried to get to the settings after activation. I think the latter.)

    BeautyPirate
    Member

    @beautypirate

    http://wordpress.org/plugins/comment-reply-notification/

    This word perfectly fine. It only sends an email for direct comments, love it.

    Raam Dev
    Participant

    @raamdev

    dish56
    Member

    @dish56

    Thanks so much, Raam Dev! I had almost given up on this plugin working, and it’s the only one that has everything I’m looking for.

    I was able to get to the settings this time without hitting a 404 page. I’ll be testing it later to make sure it works the way I need it to.

    Many thanks!

    dish56
    Member

    @dish56

    I’m disappointed to discover that this plug-in only seems to work spottily. I have several friends who are helping me test it, and while a few have received the notifications they’ve subscribed to, it seems that even more have not. I’ve checked the “Manage Subscriptions” page and have confirmed that they’ve subscribed correctly.

    Also, as administrator, I’m only receiving notifications to about half of the new comments. (I have this same problem with the notifications I should get directly from WordPress. Interestingly, the missing notifications from this plug-in are the same ones that don’t come in from WordPress; I either get both or neither.)

    I also personally subscribed to all from a different email address, and am not getting notifications for most comments.

    I was really hoping this would work. Looks like I’ll go back to sending notification emails to commenters by hand.

    Raam Dev
    Participant

    @raamdev

    @dish56 If you’re having trouble receiving standard WordPress emails (like the new comment notifications), then your problem has nothing to do with the Subscribe to Comments plugin but rather with your web hosting service failing to send emails consistently. I recommend checking with your web host regarding this issue.

    Two things that have helped me with troubleshooting email delivery problems are the ‘Email Log’ plugin (which maintains a log of all the emails WordPress sends out, including those sent by plugins) and the ‘WP-Mail-SMTP’ plugin, which allows you to manually configure an SMTP server that will be used to send your emails (I personally use Gmail and I have the ‘WP-Mail-SMTP’ plugin configured with my Gmail SMTP details, which are available within the Gmail Settings page).

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] "Replies only" subscriptions receiving "All" comments’ is closed to new replies.