• Resolved rajeevrf

    (@rajeevrf)


    I am using the Absolute URLs option for Replacing the URLs.

    I have selected the schema as “https://”, so I am supposed to enter the value in the domain name field as “domainname.com” right? But adding like this replaces the URLs like “httpsdomainname.com”. Its not adding the “://”

    So in order to make this work for now, I am using “://domainname.com” in the domain name field as of now.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author patrickposner

    (@patrickposner)

    Hey @rajeevrf,

    thanks for reaching out.

    Maybe the migration hasn’t finished?


    It works exactly as described. You select the SCHEME + your domain (without “://”), and it will replace the URLs accordingly.

    I tested it again with different deployment methods (ZIP, local..), and the result was always the same.

    Just to be sure everything was migrated, go to Simply Static -> Settings -> Utilities and click on “Migrate Settings” – the “Replacing URLs” settings hasn’t really changed, but other settings have.

    Cheers,
    Patrick

    austinjones

    (@austinjones)

    I’m noticing a similar issue with Absolute URLs. This is a new install of the plugin (haven’t used it before) but I’m noticing the Scheme option is not persisting between saves (it always goes back to https://). Looking at the generated code, all the URLs are coming out like “httpdomain” so no colons or slashes.

    • This reply was modified 11 months ago by austinjones.
    Thread Starter rajeevrf

    (@rajeevrf)

    Yes, Exactly. Even the suggested below method didn’t fix the issue

    Just to be sure everything was migrated, go to Simply Static -> Settings -> Utilities and click on “Migrate Settings” – the “Replacing URLs” settings hasn’t really changed, but other settings have.

    Plugin Author patrickposner

    (@patrickposner)

    @rajeevrf and @austinjones good catch guys, fix is on the way!

    There was indeed an issue with passing the wrong argument on changing the scheme. It’s fixed now, and the release will follow today.

    Cheers,
    Patrick

    Thread Starter rajeevrf

    (@rajeevrf)

    Thanks @patrickposner ,
    That was quick! Its working fine now!

    Durga

    (@durgacw)

    @patrickposner After updating plugin to the latest version, I’ve noticed that it is setting the default domain name as ‘://domainname’ instead of ‘domainname’ after file generation or upon refreshing or logging in again.

    austinjones

    (@austinjones)

    On a fresh install, when using Absolute URLs, I had to first save as ‘http’, hit the Migrate button under tools, then go back and save as ‘https’.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Replacing URLs – Absolute URLs SCHEME+HOST not working properly.’ is closed to new replies.