Support » Plugin: Gravity Forms Repeater Add-On » Repeater settings not applying correctly on multi-page forms

  • Resolved Jason Lefkowitz

    (@jalefkowit)


    I’m seeing some weird behavior when using the repeater plugin on forms with more than one page. When used on the first page it works fine, but when used on the 2nd or later pages, it:

    • Adds the “gfield_error” class to the field container, resulting in required fields getting the red warning background and error message that are normally only displayed when the user tries to submit the form without them; and
    • Ignores the start/min/max settings for the repeater and just shows the enclosed fields some arbitrary number of times.

    I haven’t yet been able to run down exactly where the number of times the fields are displayed is coming from; in my testing it’s usually two or three times, but it doesn’t appear to have any correlation with the values provided for start/min/max.

    The behavior is identical in both Firefox and Chrome, so it’s not a browser issue. I don’t see any warnings or errors in the browser console.

    Interestingly, if you refresh the page in the browser while on the problematic later page, it reloads with the problems resolved — the error warnings all go away, and the fields in the repeater are displayed exactly as specified by start/min/max. It’s only on the first load that the errors occur.

    https://wordpress.org/plugins/repeater-add-on-for-gravity-forms/

Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Repeater settings not applying correctly on multi-page forms’ is closed to new replies.