Support » Networking WordPress » Repair on multisite totally fail – Losting content

  • My isntallation got a problem, the 1ΒΊ blog doesn’t work anymore, it tells me to make a repair, I did it, but the repair system ignore the other blogs, it just look at the single wp_posts table instead of the wp_1_posts.

    I tried to make the repair directly on the database, by the phpMyAdmin, but it tells me there is no overload, any other problem has been detected.

    On my tables, in the blog 1 and some others blogs 6, 17, I noticed that some content has been lost by the front-end, it is not listing all the content, but reading the table, the content is still there.

    I need to understand what is going on and how can I fix this. I found few informations about it.

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have some similiar problems with blog post content or pages not showing.
    The way that I understand it works is that creation is virtual,I don’t know if looking in the blog.dir folder may reveal something, perhaps indication that the contents really exist and the problem could be in rewriting.

    edir, If you converted from WordPress single site to MultiSite, then blog 1 uses wp_posts etc. If you try a repair with phpMyAdmin and there’s nothing to repair, you still get an output that the table is OK.

    Like this:
    mysite.wp_2_posts repair status OK

    dbldee, that’s a different issue. Please make yourself your own post πŸ™‚

    ipstenu, It was an upgrade from WPMU. I will try a clean installation locally using multisite and compare the tables, I suspect there were an error on last update, maybe. But it’s strange because it was working until day 15.

    But the worst thing is the content, I lost some posts and needed to make a restore, I’m afraid of that, I’m at the end of this project and lots of contents are been sent to there almost daily.

    Backup the database, obviously πŸ™‚

    You can export the SQL and save a copy on your hard drive (which, by the way, you should do before EVERY upgrade).

    Delete the wp-admin and wp-includes folder and re-upload them from a fresh copy of WordPress. It’s possible you had an incomplete upgrade and only just now triggered what was wrong.

    First problem was a bad upgrade, now I renamed the tables wp_1 to wp_, it’s working.

    The second problem I will wait to see if it’s going happen again and try the repair.

    i have not renamed table names.

    try to uncomment define( ‘MULTISITE’, true );
    try to run /wp-admin/ms-upgrade-network.php ,
    try to set english interface .

    qdinar – Please make a NEW post explaining your whole issue. Stop bumping other, resolved, posts. Thank you.

    i have not written this to bump! let developers make possibility to do not bump! i have written this here because it appears in search engine results for this problem, and correct solution of the problem still was not written here.

    qdinar – Your problem is not the same. That’s why this solution isn’t working.

    Please make a NEW post.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Repair on multisite totally fail – Losting content’ is closed to new replies.