Support » Plugin: Autoptimize » render-blocking JavaScript and CSS in above-the-fold content

  • Resolved sporbillis

    (@sporbillis)


    Hello there,

    I installed and configured ( as much as i could/know ) the plugin and so far worked great. Don’t know if i get any sudden surprises tomorrow when i wake up like i did with w3 total cache ( bliah ).

    Although when i run a pagespeed test i get the following error that shows the autoptimize. Is this normal or should i do something?

    http://imgur.com/tCsQieN

    Thanks in advance.

    https://wordpress.org/plugins/autoptimize/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Frank Goossens

    (@futtta)

    try not forcing JS in head + consider either inlining all CSS (easy) or going for “inline & defer” (better, but more difficult). there’s more info in the FAQ, off course B-)

    frank

    Hey, thanks for the blazing fast reply, although you confused me! should i change my settings? Or this doesnt affect anything ?
    Thanks

    *note super noob when it comes to minify and the stuff your plugin does!

    Hello,

    I am sorry to ask, but I have the same PageSpeed rendering-blocking for the JS. It has the following extension: wp-content/cache/autoptimize/autoptimize_69b8692ff43fe3089da5da2ff1e86f97.php

    I used the W3TC minify before and it gaved me more less the same one as above only with the name totalcache instead of autoptimize. Ofcourse I disabled the W3TC minify settings for JS, CSS and HTML.

    My new Worpress theme works fast altough it is not filled with much content, but it is getting an obsession for almost a few nights to remove the last JS rendering-blocking message.

    http://www.2spaan.nl

    Plugin Author Frank Goossens

    (@futtta)

    try disabling the “force JS in head” option @sjorsvank.

    @sporbillis; indeed, change AO (advanced) settings 🙂

    groetjes,
    frank

    This is really wierd and I feel some kind of stuppid. But Because you mentioned it also before to sporbillis I already treid it. I must have made a mistake or something. Shame on me but thanks for the fast responce in the late night hours.

    Can you help me with one more thing maybe? I still get this message (I thought it was not that important on the score, whoops): http://ajax.googleapis.com/ajax/libs/jqueryui/1.9.0/themes/base/jquery-ui.css

    In a earlier tread you mentioned to someone else to place the query local. Do you have or know a page with a instruction? I readed a lot of pages but I can not see the forrest with all the trees anymore;)

    Many many thanks for your support so far!!

    @frank Goossens , can you guide me a bit on what to change and what to enable? i honestly have no idea what i m doing 😀

    Plugin Author Frank Goossens

    (@futtta)

    @sporbilis; go to autoptimize settings and click on “show advanced settings”. under “JS options” un-tick “force JS in head”. you might also have to tick “also aggregate inline js”.

    @sjorsvank; better ask the developer of the plugin (or theme) that includes that call, as fixing this yourself requires (some) PHP-coding.

    frank

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘render-blocking JavaScript and CSS in above-the-fold content’ is closed to new replies.