Support » Plugin: Autoptimize » Render blocking Google Font & jQuery

  • Hi there,

    This plugin is seriously awesome! Thank you for this!
    It reduced the amount of http requests enormously!

    However, I’m experiencing some small issues which I hope they can be fixed.

    jQuery is render blocking according to page speed, loading it async gives me jquery not defined errors and a white screen. How can this be fixed? (not sure if Slider Revolution is the bad guy in this)

    I’ve enabled the option “Combine and load fonts asynchronously with webfont.js”, however the font I use in Slider Revolution is not taken with it and thus is still render blocking. Is AO not taking the fonts of Slider Revolution? And of course, how can I fix this?

    Thank you in advance!

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    revslider can indeed be a pain sebas ๐Ÿ™‚

    in general:
    * you try to remove js/jquery/jquery.js from the list of AO JS optimization exclusion (but if asyncing does not work, this will probably neither)
    * you can then try ticking the box “also aggregate inline JS”, this might fix said JS error, but you’ll have to watch out for a fast growing cache size in that case (and as per the FAQ you might have to exclude specific cache-breaking inline JS from JS optimization)
    * AO only “catches” Google Fonts if they’re referenced as CSS in your HTML. chances are revslider is using other techniques to request the fonts and you’re pretty much at revsliders mercy. maybe see if you can configure revslider to use google fonts you have already, or not use them at all? B-)

    groetjes uit Belgiรซ,
    frank

    Thanks for the very fast reply!
    I’ll give “also aggregate inline JS” a try soon!

    I guess I have to take a good look at Slider Revolution again, maybe use something else in the near future.

    Groetjes terug vanuit Nederland
    Sebastiaan

    Strangely enough removing jquery from the list of AO JS optimization does partially work for Firefox and Edge (lazy loading images got broken), but the site gets a white screen on Chrome only. So unfortunately no solution here.

    “Also aggregate inline JS” sadly didn’t solve the jquery render blocking error.

    Any other solutions or do I have to live with this error? ๐Ÿ˜‰

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    you’ll probably have to learn to live with it in that case Sebas ๐Ÿ™‚

    Just a heads-up on a probable fix for this. I disabled lazy loading (or “smart” loading) on rev slider and the problem magically disappeared ๐Ÿ™‚

    Hi there, thanks for the heads up!
    Is disabling the smart loading of Rev slider solving the jQuery issue or the Google font issue?

    Any ways I’m going to disable rev slider soon anyway since it makes so many http requests. But if that means I can try loading jQuery asynchronous or optimize it. That would be awesome.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Render blocking Google Font & jQuery’ is closed to new replies.