Support » Plugin: Phoenix Media Rename » Renaming single & bulk images not working properly as of lately

  • Resolved janon123

    (@janon123)


    Hi, I love this plugin, I’ve been using it for a long time and it always worked beautifully, thanks for your hard work. But lately, I’ve been hitting a snag, I don’t know if it’s because of the latest WordPress Update but when I attempt to rename a single image, the status just spins, never turns to a checkmark or refresh the page. The filename does change behind the scenes eventually and an error is reported – I can see this in Google Chrome’s Console.

    When attempting to bulk rename, the same thing happens and only a single image behind the scenes is eventually updated but not the rest, the status is still spinning and the page never refreshes.

    So basically I’m not really able to properly rename single or bulk images. Bulk renaming is my primary use of this plugin.

    The following error is listed in Google Chrome’s Console:

    POST https://www.website.com/wp-admin/admin-ajax.php?_fs_blog_admin=true 500

    load-scripts.php?c=1…lupload&ver=5.7.2:2 POST https://www.website.com/wp-admin/admin-ajax.php?_fs_blog_admin=true 500

    send @ load-scripts.php?c=1…lupload&ver=5.7.2:2
    ajax @ load-scripts.php?c=1…lupload&ver=5.7.2:2
    s.ajax.s.ajax @ load-scripts.php?c=1…lupload&ver=5.7.2:5
    S.<computed> @ load-scripts.php?c=1…lupload&ver=5.7.2:2
    e.fn.do_rename @ scripts.min.js?ver=3.1.0:1
    s @ scripts.min.js?ver=3.1.0:1
    dispatch @ load-scripts.php?c=1…lupload&ver=5.7.2:2
    v.handle @ load-scripts.php?c=1…lupload&ver=5.7.2:2
    

    Installed Versions on my website:
    WordPress: 5.7.2
    PHP: 7.2
    Pheonix Plugin: 3.2.4

    Any idea what the issue can be? I’d appreciate any help.

    Best,

    Jane

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author crossi72

    (@crossi72)

    Hi @janon123,
    many thanks for reporting, some other people have reported similar issues, but I’ve never been able to reproduce it.

    I released a new version a few hours ago, but I don’t think it can solve your problem, the update is related to WPML compatibility.

    I’ll investigate again this issue early next week.

    C.

    Thread Starter janon123

    (@janon123)

    Thanks for your reply and for the information. I apologize for the repeat reporting, I did search the forum before submitting it and couldn’t find anything, sorry if I missed it.

    I did install the WPML plugin a few weeks back to see if it would be a good fit for my site and it wasn’t so I did remove it not long after installing it. Maybe it left something behind that’s interfering with your plugin. You could be right so I tried running the “Plugin Garbage” plugin to see if there are any remaining parts of the removed WPML plugin but it didn’t catch anything, but then again that plugin hasn’t been updated in a few months so it’s probably not compatible with the latest WordPress.

    In case it’s worth noting, I forgot to mention yesterday, my debug log has this listed whenever I attempt to rename a file:
    PHP Notice: Undefined variable: options in /wp-content/plugins/phoenix-media-rename/class-media-rename.php on line 748

    Thanks again!

    Plugin Author crossi72

    (@crossi72)

    Hi @janon123,
    thank you for reporting: there was an error in Phoenix Media Rename’s options management.

    I just released version 3.2.5 that fixed the issue, thank to you it has been really easy to find the source of the problem 🙂

    Version 3.2.4 fixed the issues with WPML, now you can safely use both plugins.

    Let me know if this release fixes your issue (only the first image was renamed), on my development and production servers everything was running, but the error you reported was present.

    C.

    Thread Starter janon123

    (@janon123)

    No problem at all, I’m happy to help. Thank you for being so involved and for your continued work with the plugin, it’s much appreciated.

    I updated the plugin, tested it out again, and the “PHP Notice: Undefined variable” error reported is now fixed, thank you. Image titles still couldn’t be renamed properly as a single or in bulk…so I checked my server error log again and noticed a PHP error “memory exhausted” I upgraded my WordPress memory limit from 256 MB to 512 MB and it solved the problem – YES! I was able to rename images again single and in bulk again.

    In case anyone else is experiencing the same issue as me – the problem isn’t with the plugin but with the latest WordPress update and the PHP upgrade. The solution is super simple. Add the below code to your wp-config.php file just before the /* That’s all, stop editing! Happy blogging. */ line:

    define( ‘WP_MEMORY_LIMIT’, ‘512M’ );
    define( ‘WP_MAX-MEMORY_LIMIT’, ‘512M’ );

    Thank you again for your awesome support. YOU ROCK!!!

    Plugin Author crossi72

    (@crossi72)

    Thank you for reporting both the issue and the solution 🙂

    Now I understand why I couldn’t replicate the problem: I used a memory limit too high to trigger it.

    I’ll reduce the memory limit on my development server to see if it is possible to let the plugin work with 256MB or RAM.

    Happy renaming!
    C.

    mlabash

    (@mlabash)

    As of just installing this today 10-21-21, I am still getting the same problem as mentioned earlier in the thread.

    Plugin Author crossi72

    (@crossi72)

    Hi @mlabash,
    can you tell me which theme and active plugin are you using?

    I need this information to try to replicate the issue on a development server.

    Thank you for reporting the issue.
    C.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.