Support » Theme: Pen » Renaming a section in the archive

  • Hi, how do you please rename the “category” in the article archive? I would need it for the Czech “Rubrika”. Thank you

Viewing 14 replies - 1 through 14 (of 14 total)
  • Theme Author htmlpie

    (@htmlpie)

    Hi there,

    It is already translated so it should say that, unless the WP or user language is not set to Czech?

    Thread Starter gomanek

    (@gomanek)

    Thank you for answer,
    yes, the language is set to Czech, nevertheless “Category” is displayed instead of a “Rubrika”, etc …
    This is the site: https://www.auto-moto.name/tipy-a-rady/

    Theme Author htmlpie

    (@htmlpie)

    That part comes from the WP itself, there is probably something wrong with the WP language files, the .mo files in particular.
    I’d Install a plugin like LocoTranslate to recreate the .mo files.
    https://wordpress.org/plugins/loco-translate/

    Just change the translation for “Category” and save, which should be there so just type it again and save your changes so that it’d recreate the .mo files.

    Hope it helps!

    Thread Starter gomanek

    (@gomanek)

    Thank you for answer,
    I tried it, see here: https://ibb.co/vwcYsjN
    No change ๐Ÿ™

    Theme Author htmlpie

    (@htmlpie)

    I assume you do not have a cache plugin with “static page” generation enabled? if you do then you may need to clear the cache.
    Otherwise, try removing the .mo files from /wp-content/languages and then redo that, LocoTranslate should create them from scratch.

    By the way, the string in the screenshot is not exactly the one you have on that page, it’s “(archive title) Category:”, but saving the language file would recompiled the .mo file anyway, so it doesn’t really matter unless there is no translation for that one (archive title) which is not very likely.

    Thread Starter gomanek

    (@gomanek)

    It’s a mystery to me:
    – Web cache is not set
    – Deleting mo files and re-creating them did not help
    – When I change the language of the site to another, it appears fine
    – when I upload via FTP CZ language from another functional website with PEN theme, the “category” is still displayed
    That just doesn’t make sense to me ๐Ÿ™‚

    Theme Author htmlpie

    (@htmlpie)

    Are you using any other language-related plugin? like PolyLang or WPML.
    Also, does it display fine with other themes or is it just the theme Pen? on this site, not the other one.

    Thread Starter gomanek

    (@gomanek)

    Hello,
    no, I’m not using another translator.

    I have now found one interesting thing:
    – when wordpress version 5.4.4. the “archiv rubriky” is displayed correctly
    – “category” error is displayed after updating to WordPress 5.5.3.

    • This reply was modified 3 months, 2 weeks ago by gomanek.
    Thread Starter gomanek

    (@gomanek)

    One more thing occurs to me. Is it possible to modify the template so that the section does not display the title “category” with an image of the folder, but only the name of a specific section?

    Theme Author htmlpie

    (@htmlpie)

    Hi there,

    I’d suggest installing the “Beta Tester” plugin to upgrade to version 5.6, if it didn’t fix the issue then maybe you should submit a ticket and report the bug to WP team, I’m sure they would want to know.

    Yes, you can hide it, add this CSS through Appearance → Customize → Additional CSS:

    body.category h1 span.pen_heading_main {
      display: none;
    }

    The icon can be removed through Customize → Content → List Views.

    Hope it helps!

    Thread Starter gomanek

    (@gomanek)

    Hello,
    Thank you for the valuable advice.

    a) The “beta tester” plugin did not help, the same is still displayed.
    b) The icon according to the settings is already OK (not displayed)
    c) CSS code did not change anything: https://ibb.co/2YG484h

    Am I setting something wrong within CSS?

    Theme Author htmlpie

    (@htmlpie)

    Sorry for the late reply!

    The CSS code may need “!important”, like this: display: none !important;.

    If the Beta Tester plugin did not help then it must be something in the language files; try copying them from the working site to this one.

    Thread Starter gomanek

    (@gomanek)

    Thank you,
    for your answer.

    Great, adding โ€œ! Importantโ€ helped ๐Ÿ™‚

    I’ve copied language files several times, from a work website, from wordpress.org, from another website … nothing helped. I’m afraid the problem will be the transition from WordPress 5.4.4. on 5.5.3., but I don’t know where …

    Theme Author htmlpie

    (@htmlpie)

    What about a fresh installation of the WP and then exporting everything (Tools → Export) and importing them to the fresh one?

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.