Support » Plugin: All In One WP Security & Firewall » Rename Login Page error with WP 5.7 RC3

  • Resolved vtad

    (@vtad)


    I know its to soon, when I activate the rename login page feature login produces:

    Fatal error: Cannot redeclare retrieve_password() (previously declared in /home/www/proto/wp-includes/user.php:2671) in /home/www/proto/wp-content/plugins/all-in-one-wp-security-and-firewall/other-includes/wp-security-rename-login-feature.php on line 359

    Deleting the function retrieve_password() in wp-security-rename-login-feature.php resolves the problem.

Viewing 15 replies - 16 through 30 (of 35 total)
  • iobaid

    (@iobaid)

    Waiting for a fix as well.

    Yusup Ali

    (@fileour)

    I have also the same problem after WordPress update.

    Yusup Ali

    (@fileour)

    After disabling the rename of the admin login page feature. Now it will fin. But it is not a permanent solution…

    langhof

    (@langhof)

    Another one

    Workaround:

    Database (phpMyAdmin) in table ‘xx-options’ search for ‘aio_wp_security_configs’ as “options_name”.
    Edit this value: Search for: ‘s:22:”aiowps_login_page_slug”;s:7:”<your_door>”;’ an delete it.
    Now you can login via ‘/wp-admin’

    • This reply was modified 2 months ago by langhof. Reason: found a temp solution for me
    dananimal

    (@dananimal)

    This issue has affected one of our sites.
    We regained access to the backend by renaming the /all-in-one-wp-security-and-firewall/ directory.
    As such we cannot deactivate only the rename admin page feature.
    If we log in and then restore the plugin directory name we are logged out and the Critical Error occurs again.
    And as far as I’m aware we will not get any patch offered to rectify the issue.

    Is there a way through CLI or otherwise to do this without access to the plugin in the backend?

    • This reply was modified 2 months ago by dananimal. Reason: typo
    sadragro

    (@sadragro)

    i have same problem…
    we use this plugin in many many websites …
    please fix it soon…
    thank you in advance

    sadragro

    (@sadragro)

    new version is relased 5min ago…
    thank you!

    Plugin Author mra13

    (@mra13)

    This has been fixed. Please update the plugin to the new version v4.4.8

    heinohund

    (@heinohund)

    Do I have to do anything – Or will the plugin auto update and solve it by itself?

    Thread Starter vtad

    (@vtad)

    Resolved with update

    Plugin Contributor mbrsolution

    (@mbrsolution)

    @heinohund, you need to update the plugin unless you have Enable auto-updates enabled for our plugin.

    Kind regards

    AlikSite

    (@aliksite)

    How I can update plugin if I can’t login to wordpress?

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    Step 1 = Use cPanel file manager (or FTP) and temporarily rename this plugin’s folder. Rename the plugins folder name from all-in-one-wp-security-and-firewall to tmp-all-in-one-wp-security-and-firewall. This process automatically disables the plugin in your site.

    Step 2 = Log into your site using the standard login URL – ie, yoursite.com/wp-login.php. Then rename the folder back to its original name all-in-one-wp-security-and-firewall.

    Step 3 = Update the plugin to the latest version.

    Let me know how you go.

    Thank you

    glennhofman

    (@glennhofman)

    Updated with the ftp method, now the following error appears?

    WP_Scripts::localize werd verkeerd aangeroepen. The $l10n parameter must be an array. To pass arbitrary data to scripts, use the wp_add_inline_script() in /************/public_html/wp-includes/functions.php on line 5313

    Is this caused by the plugin?

    nxplaygames

    (@nxplaygames)

    The problem has already been solved please update the plugin to version 4.4.8

    Thank you very much to the developer for resolving it quickly.

Viewing 15 replies - 16 through 30 (of 35 total)
  • You must be logged in to reply to this topic.