Support » Plugin: WP Cerber Security, Anti-spam & Malware Scan » Removing WP-Cerber leads to losing wp-admin styles

  • Resolved Jurrie

    (@jurrie)


    I removed WP-Cerber (the free version, wich I’m very happy with) to give my wife temporary uncomplicated access. After logging in, she was presented with an unstyled WordPress dashboard.
    I re-installed WordPress to no avail. Also some hacks from the internet didn’t work. At last, I re-installed WP-Cerber, which wasn’t in the repository anymore, but I managed to download a copy from their site.

    What was going on? What do I have to do to safely uninstall the plugin?

    Thank you! BTW I LOVE the plugin!

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Same issue here!! – I need to clear all plugins on a site. Removing the deactivated Free WP-Ceber makes the dashboard un useable

    Plugin Author Gregory

    (@gioni)

    Hi! You need to remove the plugin by using “Delete” link on the “Plugins” admin page. To temporarily disable the plugin, use the “Deactivate” link on the page. There are no other options. Manual removal of the plugin folder is not supported.

    @pst247

    @gioni

    I used the Decativate link then the Delete link. Tried now on multiple sites and the same thing happens. The back end dashboard becomes unusable.

    I have the same issue. Any fix yet?

    Plugin Author Gregory

    (@gioni)

    @pst247 Try to log in using a different browser. I believe some cache is involved.

    Thread Starter Jurrie

    (@jurrie)

    Thank you Gregory for your reply. However, removing the plugin in the canonical way is not always an option. Sometimes one is forced to rename it with FTP in order to disable it. Reaching the max inlog attempts, forgetting the custom admin URL, you name it. In this case, you are presented with an unstyled WordPress Dashboard. I believe there’s something going on in the .htaccess that does the trick. It would be nice to have a straightforward howto from you, as what to do in case of emergency.

    Thank you very much for all this free goodness anyway. Have a great day/evening!

    @jurrie Agreed

    @gioni This ins’t a cache thing. Client went to unstyled dashboard and reported the issue as well. Have tried this on a couple of sites with 3 browsers. Ended up restoring backups and leaving the plugin disabled (with an alternative in place) until this can be resolved and I can trust it not to mess anything up.

    new browser different computer, etc all tried… No success! Still no CSS in WP Admin for me…
    How can I resolve this? Help needed please….

    This solved it:

    I had the same issue a few months back I tried this and this works for me.
    
    define('FORCE_SSL_LOGIN', false);
    define('FORCE_SSL_ADMIN', false);
    define( 'CONCATENATE_SCRIPTS', false );
    define( 'SCRIPT_DEBUG', true );
    try to load wp-admin with SSL.
    
    After reloading it looks OK, maybe after re-login, set SCRIPT_DEBUG to false.

    https://wordpress.stackexchange.com/questions/323250/wordpress-wp-admin-css-not-loading

    Plugin Author Gregory

    (@gioni)

    I believe there’s something going on in the .htaccess that does the trick. It would be nice to have a straightforward howto from you, as what to do in case of emergency.

    Your assumption is correct. If you have to remove the wp-cerber folder, you also have to remove all the lines between the following lines in the main .htaccess file.

    # BEGIN WP CERBER GROOVE
    # END WP CERBER GROOVE

    @pst247
    @onlineopvoedhulp

    @gioni – thanks for the update and guidance. I’ll check this out tomorrow.

    @gioni your instructions above resolved the issue – thank you.

    Nathan

    (@nathan1776)

    I have a trick for this. I rename it to pluginname.old and reinstall wp cerber to re-enable CSS just to go back to plugins and delete it or re-enable. One of the two – I can’t recall which.

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.