WordPress.org

Forums

Stargazer
Removing "trackbacks and pingbacks" from each page (17 posts)

  1. jjcrow
    Member
    Posted 1 year ago #

    Could you please tell me also how can I remove “Comments are closed, but trackbacks and pingbacks are open.” from the pages which have comments closed? I disabled comments on each page. Everything under Discussion is unchecked. Where do you go to get rid of this? The theme is Stargazer by the way.

  2. jjcrow
    Member
    Posted 1 year ago #

    Can Anybody help me with this please?

  3. SundayMorning
    Member
    Posted 1 year ago #

    Hello,

    If you go to your admin panel -> Pages -> an single page. Then click the drop-down menu at the very top right corner (that shows which options to display). Sadly, my WP isn't in English, so I'll just have to guess on your translations. Make sure the boxes "Comments" is checked. Now scroll down on your site until you see the Comments box. Uncheck "Allow comments" and "Allow Trackback and Pingbacks". That should solve your problem.

    Sadly, you have to do this on every single page you have already created. However, after you make a new page with those two unchecked, the next page you create will have it off by default.

    /Sunday.

  4. jjcrow
    Member
    Posted 1 year ago #

    Hello!
    I did what you said, but all of those boxes are already unchecked. Plus in Settings > Discussions, all of the boxes that mention allowing comments are unchecked. The odd thing is that not every page has the Comment trackbacks on the bottom of the page. Is it some place else that I need to work on? I really appreciate your help and hopefully I can get this fixed.

  5. SundayMorning
    Member
    Posted 1 year ago #

    Are you sure you removed the check box from "allow trackback and pingbacks" as well?

    Could you please link me to your site so that I could look at it?

  6. jjcrow
    Member
    Posted 1 year ago #

    If that box is under Discussion, then yes. Sorry for not linking the site here. http://www.canadaneedsourlady.org
    There are a few pages that don't have it listed way at the bottom, like: http://www.canadaneedsourlady.org/public-square-rosary-rally/supplies/
    but the Map does. So it's strange.
    Any suggestions?

  7. SundayMorning
    Member
    Posted 1 year ago #

    Are you sure the settings are not set differently for each page? If not, I am afraid I do not know what is wrong.

  8. jjcrow
    Member
    Posted 1 year ago #

    How do you tell? Do you go back to what you said the first time and check those boxes or is there some other place to check?

  9. SundayMorning
    Member
    Posted 1 year ago #

    Yes. On every page you find that text.

  10. jjcrow
    Member
    Posted 1 year ago #

    Well...I looked it over again; edited again; made sure everything was unchecked and nothing changed. I can't figure out where else to look. Thank you very much for trying to help me!

  11. SundayMorning
    Member
    Posted 1 year ago #

    Sorry I couldn't help you more. If you find the solution, you can help others who later have the same problem by posting it here when you close the thread. Good luck!

  12. jjcrow
    Member
    Posted 1 year ago #

    Will do and thank you!

  13. ztig
    Member
    Posted 1 year ago #

    My best guess is that you go to "Pages" in your admin-panel, and then check the "mark all" box at the top of the page before choosing Edit in mass actions.

    Uncheck the comment box, and press save.

    Even thoug comments have been disabled in settings, pages that were already created will not be affected by changing that setting.

  14. queridamolly
    Member
    Posted 11 months ago #

    My coding skills are very basic, but I accomplished this by editing the misc/comments-error.php file.

    I changed:

    <p class="comments-closed pings-open">
    		<?php
    			/* Translators: The two %s are placeholders for HTML. The order can't be changed. */
    			printf( __( 'Comments are closed, but %strackbacks%s and pingbacks are open.', 'stargazer' ), '<a href="' . esc_url( get_trackback_url() ) . '">', '</a>' );
    		?>
    	</p><!-- .comments-closed .pings-open -->

    to:

    <p class="comments-closed pings-open">
    		<?php
    			/* Translators: The two %s are placeholders for HTML. The order can't be changed. */
    			printf( __( '', '' ), '<a href="' . esc_url( get_trackback_url() ) . '">', '</a>' );
    		?>
    	</p><!-- .comments-closed .pings-open -->

    I added my edited comments-error.php file to my child theme, within a 'misc' folder.

    I'm sure just deleting things is leaving the code a bit sloppy. If there's a better way, I'm all ears.

  15. jjanthony
    Member
    Posted 11 months ago #

    Sunday Morning I believe you misunderstand his intention; he has already used the checkboxes, but wishes to do away with the text saying the comments are closed. Need to find the page template it is appearing on and change the code there. I'm doing this right now so when I figure it out (again - I've done this before!) I'll post.

  16. jjanthony
    Member
    Posted 11 months ago #

    Here's what I did, a quick fix in style.css, change font sizes to 0:
    #comments {
    font-size: 0px;
    font-size: 0rem;}

    I'm using a different theme, but you should be able to find it in yours. Older post so you probably did, but for future reference anyway...

  17. Justin Tadlock
    WordPress God
    Theme Author

    Posted 11 months ago #

    All you need to do is copy the stargazer/misc/comments-error.php template into your child theme (child-theme/misc/comments-error.php). From that point, you can either alter the text or remove it altogether.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic