Support » Theme: Twenty Twenty-One » Removing the words “published in” within a block attachment page

  • Resolved perennialheights

    (@perennialheights)


    Hello,

    I have turned the blocks onto my homepage into attachment pages. Within those pages, underneath the image I have uploaded it shows the words “Published in Welcome to Perennial HeightsFull size960 × 1280Edit”. How do I remove the words “Published in….” in each of these pages? Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • This was tricky 🙂

    So here’s a solution with CSS … add this to “Customizer – Additional CSS” …

    .attachment .posted-on {
    text-indent: -99999px;
    position: relative;
    display: block;
    }
    .attachment .posted-on>a {
    position: absolute;
    left: 0;
    text-indent: 0;
    }

    Let me know if that works and I’ll add it as an option in Options for Twenty Twenty-One plugin.

    Oliver

    Thread Starter perennialheights

    (@perennialheights)

    Glad you confirmed it was tricky, I was searching for hours! The CSS solution you provided is soooo close. Thank you! It removed everything now except the size of the image, so now it just says “960 × 1280Edit”

    Just had a look, you’ve not quite pasted that CSS in right. There should be a “more than” sign in-between “.posted-on” and “a”.

    Double check that and you’ll find it works 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.