WordPress.org

Support

Support » Themes and Templates » Removing the indent: Recent Posts

Removing the indent: Recent Posts

  • I have to work with a theme called Ice 3.17.

    When I use the Recent Posts widget in the sidebar, or even the Special Recent Posts plugin, the headline is ok but the actual list of recent blog posts is very indented.

    I looked all through styles.css, but I could not find where to fix this.

    The search box does the same thing: the Search headline is fine, but the contents of the widget (the search form) are indented. Things look sort of like this:

    Blog Posts
    ________Blah blah blah

    Search
    _________[searchbox]

    Can anyone tell me where in the code I can find the fix for this? I would like it to look more like this:

    Blog Posts
    Blah blah blah

    Search
    [searchbox]

    Thank you!

Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator Michael

    @alchymyth

    Forum Moderator

    please use a web tool such as firebug to investigate these kind of formatting problems – http://getfirebug.com/

    or at least post a link to your site.

    The site is: http://doranandmurphy.com/

    The problem is the way the posts display under Attorney Blog on the sidebar.

    Thank you.

    Does anybody have any ideas?

    esmi

    @esmi

    Forum Moderator

    Have you tried using Firebug yet?

    No, I think the theme is okay, it’s just that the people who have the site don’t like the way the Recent Posts display, with a large indent. I think the theme is probably built to do that, and I just need someone to point me in the direction of where I would find the code to change it, and how.

    Any help would be much appreciated.

    esmi

    @esmi

    Forum Moderator

    Then I suggest you use Firebug and start tweaking the CSS on the recent posts.

    But where do I find the code? I don’t even know where to look. Is it in the stylesheet, functions.php, or right_sidebar.php. I really don’t have a clue where it would be. Do you have any ideas?

    esmi

    @esmi

    Forum Moderator

    That’s what Firebug is for.

    Ok, thanks, I’ll see what I can find with it.

    Ok, well it highlights the entire sidebar widget area under Attorney Blog when I mouseover the “ul” below, in Firebug:

    <div id="wdg_specialrecentposts-3" class="widget Special Recent Posts">
    <h2>Attorney Blog</h2>
    <ul>
    </div>

    I’ve seen the ul many times when I was poking through the code. How do I put 2 and 2 together and find where this happens in the stylesheet or the .php files in the theme, and change it so it does not indent so much?

    Is it something to do with changing the settings of an unordered list?

    esmi

    @esmi

    Forum Moderator

    This is a CSS issue – so you need to make changes to the theme’s stylesheet.

    CSS Tutorials
    Learning CSS

    Ok, thank you very much.

    The problem is that I experimented with the stylesheet many times and was not able to do what I needed. I am not experienced with CSS.

    Are there any clues you know of, as to where I might find how to remove the indent? I looked at many margin and padding settings but to no luck.

    esmi

    @esmi

    Forum Moderator

    As I said earlier, that’s what Firebug is for. If you cannot manage this yourself, you may want to consider hiring someone.

    Ok, I’ll keep looking. Thank you.

    If anyone else has experience with the Ice theme I would much appreciate it.

    Target the indentation in your CSS with…

    .widget ul { margin-left: -35px; }

    This will get it close, tested only in Chrome…your results in other browsers may vary.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Removing the indent: Recent Posts’ is closed to new replies.