Support » Fixing WordPress » Removing the comment section from my pages

Viewing 5 replies - 1 through 5 (of 5 total)
  • It depends on what theme you are using.
    If your theme just uses the default page template, “page.php,” then there is likely a line in there like:
    <?php comments_template( '', true ); ?>
    Remove that or comment it out and you should be good to go.

    i need to remove the comments box on all my website pages. how can i do that? i dont want any posts or comments.

    Excela6, are you saying you just do not want any commenting to occur on your site?

    If that is what you are asking:
    1. Go to Settings > Discussion
    2. Turn off commenting there

    If that is not what you are asking, then please elaborate.

    Take care,

    the comment box is still visible…. how can i remove that box completely?


    If you had comments on when you made pages earlier, those pages will still allow commenting and show the box.

    1. Go to those Pages (Editing)
    2. In the “Discussion” box, turn off commenting.
    NOTE if you cannot find the Discussion box, check the “Screen Options” at the top of your page.

    Give it a shot,

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Removing the comment section from my pages’ is closed to new replies.