Support » Fixing WordPress » Removing page number for older posts

  • Resolved everythingafter


    I am having trouble removing the page numbers at the bottom of my theme that will take users to older posts. The person for whom I’m making the website wants that option removed altogether and for there to be no page numbers at the bottom at all. She just has a basic menu at the left and doesn’t need the archive feature.
    Any help would be appreciated. Oh, I am using the Mantra theme.
    Here’s what I have tried so far (All these steps were done to files in the Mantra theme):
    • Commenting out the “Pagination” section in the stylesheet.css file. While this removed blocked links at the bottom and cut out the formatting, I still have the page numbers at the bottom. They just are not formatted anymore.
    • Disabling the “pagination” option in the theme’s defaults.php file. Didn’t do anything that I could tell.
    • Removed this code from singles.php: <div id=”nav-below” class=”navigation”><div class=”nav-previous”><?php previous_post_link( ‘%link’, ‘<span class=”meta-nav”>«</span> %title’ ); ?></div><div class=”nav-next”><?php next_post_link( ‘%link’, ‘%title <span class=”meta-nav”>»</span>’ ); ?></div></div><!– #nav-below –>
    Interestingly, this did achieve what I wanted on a single post (See the Genesis in the link below), but as of yet, I’ve got no solution for the main front page. I also tried looking for similar code in all the other main .php files for that theme to no avail.
    • Last resort was a Google search, but that was not successful.
    Here’s the link to the site:
    I also couldn’t find any options in the Mantra settings to remove navigation or disable archiving.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Perhaps this (archive.php) may be doing it?

    <?php endwhile; ?>
    				<?php if($mantra_pagination=="Enable") mantra_pagination(); else mantra_content_nav( 'nav-below' ); ?>
    			<?php else : ?>

    FYI: Here is what I found to fix it. I found similar code as above in the main index.php file and just changed Enable to Disable since deleting the whole block of text caused a php error.
    Thanks for pointing me in the right direction,

    Glad to note that you could solve the problem. 🙂
    Please mark the thread as resolved.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Removing page number for older posts’ is closed to new replies.