WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Removing no-follow in 2.3.1?

[Resolved] Removing no-follow in 2.3.1?

  • I recently added a do follow plugin to my site and it worked just fine with 2.3, but today I’ve upgraded to 2.3.1 and absolutely NOTHING is working to keep a comment author’s name linked to their URL. I’ve tried going in and editing the comment to include the URL, but it won’t take. I’ve tried various other do-follow plugins, they don’t help. I’ve deactivated and removed my other plugins. I’ve changed the code in my comment-template.php page, no go.

    Can anyone help, please?

Viewing 12 replies - 1 through 12 (of 12 total)
  • So I’ve been surfing around and it seems like a popular complaint, wanting to remove the no-follow attribute. Unfortunately, none of the fixes I have found so far have helped me at all. I’ve tried every do-follow plugin I could find, I’ve been reading other support threads here and have tried going in fixing the code – as described in this thread – no fix for this in 2.3.1 apparently. I have deactivated and removed other plugins, I don’t know what else to do, but I really want the no-follow turned off.

    What changed between 2.3 and 2.3.1 that could be affecting this?

    I don’t mean to be a pain, forgive me for bumping. I haven’t found a solution to this yet.

    I don’t know of any working plugin… but if you remove this:
    rel='external nofollow' from line 48 in the wp-includes/comments-template.php – doesn’t work?

    No, I’ve done that, it hasn’t helped at all. 🙁

    What’s the best/safest way to downgrade to 2.3? Maybe that will fix the problem, for now.

    Hmmm. I just tested it on a WP 2.3.1 install – there is no “do-follow” plugin or anything, just removed that code from the comments-template.php and it works…

    I’ve double-triple-quadruple checked that line of code on my own comments-template.php page, I’ve altered it as suggested. Grr.

    Your “nofollow” doesn’t come from that file! In that file it has only single quotes around it [‘] and in your soruce code it has double quotes [“] – so it is inserted by something else.

    Ah…that’s kind of why I wondered if there was something altered between 2.3 and 2.3.1 that was causing the trouble…thanks for popping in to have a look. 🙂

    Also – how is it that I can’t view my own source code? Whenever I right click to “View Source” I get a box saying I don’t have permissions…but apparently you can see it?

    1. I don’t know what to say about the versions. As I said above: I did try this hack on a 2.3.1 and it worked!

    2. I could see the source code… although sometimes your site acts in a strange way: at my first attempt to post a comment it wanted me to download the post-comment file 🙂

    Buh? Weird!

    Well, I’ve started using the comment luv plugin today, it links to a comment author’s latest blog post in the comment they leave, so maybe that’ll be a kind of “quick fix” for now.

    Well, I’ve upgraded to 2.3.2 today, and went into the comment-template.php and removed that bit of code, and the do-follow seems to be working once again. So, yay! Hope it stays that way, heheh. 😀

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Removing no-follow in 2.3.1?’ is closed to new replies.