WordPress.org

Forums

Removing /index.php/ from my urls (8 posts)

  1. sunil ch
    Member
    Posted 1 year ago #

    hi i have worked an wordpress site in linux hosting with apache server
    and deployed it on client server
    client has windows hosting and server is IIS.

    i have uploaded the all the file through FTP and
    and dump the database with phpmyadmin in client server

    here the problem is all the urls is
    " http://dgiint.com/index.php/industries/ "

    domain name is dgiint.com
    i just want to remove /index.php in the url and want to make
    domainname/postname

    i had gone through the settings/permalinks
    strange here also i can sea the same format for all types

    her is the permalinks menu

    Common Settings

    Default http://dgiint.com/?p=123
    Day and name http://dgiint.com/index.php/2013/07/18/sample-post/
    Month and name http://dgiint.com/index.php/2013/07/sample-post/
    Numeric http://dgiint.com/index.php/archives/123
    Post name http://dgiint.com/index.php/sample-post/
    Custom Structure http://dgiint.com/index.php/%postname%/

    can any body help me with this

    thanks in advance guys

  2. Pioneer Web Design
    Member
    Posted 1 year ago #

    Change to:

    Custom Structure: /%postname%/

    Do not add the domain or index.php

    http://codex.wordpress.org/Using_Permalinks#Using_.22Pretty.22_permalinks

  3. sunil ch
    Member
    Posted 1 year ago #

    i have tried that after changing the permalink i had gone through browse my site but i got error
    "
    The page you requested is NOT AVAILABLE

    A general error has occurred "

  4. Pioneer Web Design
    Member
    Posted 1 year ago #

    That is most likely due to your server environment which appears to be Microsoft-IIS/6.0.

    I would move to a Linux Server on a well known host.

  5. Pioneer Web Design
    Member
    Posted 1 year ago #

  6. sunil ch
    Member
    Posted 1 year ago #

    i cant do this because it was client site

  7. Zoee
    Member
    Posted 1 year ago #

    Are your URLs correct in Settings > general? If so it probably is the windows hosting, I had this issue a year or so ago and had to get the client to change their hosting to linux.

  8. Pioneer Web Design
    Member
    Posted 1 year ago #

    You cannot use Permalinks in WordPress unless the host has a mod.expires.c module or other method to rewrite url's.

    This may or may not help.

    http://www.kylecaulfield.com/permalink-for-wordpress-iis-6-mod_rewrite-fixed-free

    If your client wants this functionality, they should move to a new host. II6 is a very old and unsupported server env and will likely have issues with WP, themes, and plugins in general.

    http://www.iis.net/downloads/microsoft/url-rewrite

    IIS6 was released with Windows Server 2003. Yes, ten years ago. The mainstream product life cycle has ended. As such, consider it unsafe.

    http://support.microsoft.com/lifecycle/default.aspx?LN=en-us&x=13&y=12&p1=3198

Topic Closed

This topic has been closed to new replies.

About this Topic