Support » Plugin: WP-UserOnline » Removing/Hiding the Archive

  • Hi,

    I’m getting the word ‘archive’ appearing many times in my User Online page, and after checking in the ‘WordPress Fixit’ forum, they’re convinced that it’s not a WordPress issue.

    A couple of examples are:

    My Website Title » Archive Privacy Policy – My Website URL

    or

    My Website Title » Archive My Homepage URL

    …and can be seen to full effect on MY WEBSITE

    I’ve been looking at this issue for a while now, as it’s mentioned that Google sees archives as duplicate content, and I actually have all the archives (author and date) disabled in my SEO plugin.

    So I was wondering – is this just something that the plugin is addding and it’s not really linked to any archive at all, or is it something that’s being added by WordPress, or is it something else that can be easily fixed?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Lester Chan

    (@gamerz)

    The plugin doesn’t touch your page title (there is no reason to). My guess it is added by another plugin.

    Thread Starter deeveearr

    (@deeveearr)

    Hi @gamerz

    I’ve just tried your theory in troubleshooting mode, with all the other plugins disabled and running WordPress 2020 theme:

    HERE

    …so it’s not added by another plugin or the theme.

    Plugin Author Lester Chan

    (@gamerz)

    After actually digging into the plugin (been a while) Actually, I am wrong, you are right. It is added by the plugin. Wow I wonder why did I do that last time.

    I removed it https://github.com/lesterchan/wp-useronline/commit/5c88018402848d193415f942b4bb29ce758e1c50, will tag and release after that. You can do the same to your copy as well.

    Thread Starter deeveearr

    (@deeveearr)

    Thanks Lester, probably added following a shotfest at the pub 🙂

    Thread Starter deeveearr

    (@deeveearr)

    I tried swapping the old line of code, and replacing it with the new line of code, and the bottom few instances still have ‘archive’ attached to them.

    Dunno, probably needs a half hour or so to re-rack so that all entries start to use the new code.

    Thread Starter deeveearr

    (@deeveearr)

    Just checked again, and all of the ‘archive’ labels have indeed disappeared.

    Thanks for your help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.