WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] removing excerpt from single.php

[Resolved] removing excerpt from single.php

  • Hello everyone.

    I’ve been struggeling to find a solution to my problem in the great wide opens of the internet. In my single.php I am displaying the whole content of a post. So far so good, but what I do not want to bhe displayed is the excerpt I use for my related and recent postlists. To bad I cant find a way to tell wordpress to not show the excerpt when giving out the content in the loop.

    you can check the problem on http://www.christianzschunke.de/neu/?p=37 below the video.

    I’d appreciate any ideas on how to solve the problem.

    thanks in advance.

Viewing 8 replies - 1 through 8 (of 8 total)
  • If you are using the more tag to create the “excerpt” then you might find this solution useful:

    http://wordpress.org/support/topic/366353?replies=2

    Thanks for your reply mfields, unfortunatly it didnt really apply to my situation, as I am using a manualy written excerpt for each article. All I am looking for is a way to toggle the display of the manual excerpt off for the_content in the loop.

    Hmmm…. That is strange, the excerpt should not be showing up in single.php. If you could post the code from your single.php, I’ll take a look at it. Please paste here: http://wordpress.pastebin.com/

    Do you have a plugin installed that would add the excerpt to the the_content filter? …or possibly a custom theme mod?

    Have never heard of this happening before 🙂

    Hey mfields.

    I really appreciate your commitment. As I am trying to get started with wordpress and write my theme from scratch I naturaly have some plugins allready, none of wich would add the excerpt to anything though.

    Anyways, I uploaded the single.php to pastebin and would be pleased if you could take a short look. Thanks again for your time.

    http://wordpress.pastebin.com/ypbmpxLc

    tamray,
    your template looks fine and is using the_content() to display post content… the thing is that you “excerpt” is a part of the post content and you have used the more tag. Please double check your post. I am positive that this is the case because, when I vied the source of your page, this <span id=”more-37″></span> was in the source.

    best,
    Mike

    Hi Mike,

    thats true, I used the <!– more –> tag to only display the headline on my index.php. Since I am a big fan of trial and error I set up the following experiment – I renamed my index.php to single.php and uploaded both. What happened is really weird. The excerpt does NOT show up below the post on the index.php but it DOES show up on the single.php. Keep in mind, both files are identical. It has either something to do with wordpress displaying excerpts by default on a the single.php or some crazy settings on my install.
    Unfortunatly everyone who hast questions about the excerpt in wordpress is more concered with a solution on how to display it wich is kinda funny concidering my problem.

    Anyways, I’ll investigate some more into that matter and keep this thread updated as I go if someone else ever runs into this problem.

    Allright, so after switching plugins on and off with identical index and single phps I located the source of all problems. YARRP (Yet another related post plugin) was causing the_content to display the_excerpt at the bottom of my posts. By deactivating the plugin everything went back to normal.

    Now I only need to find another related post plugin that lets me style the list of the results.

    Thanks alot for the hint on your second post Mike, I really appreciate the help you and others are offering here on wordpress.org.

    best regards,
    Christian

    Christian,
    No problem, glad I could help you work it out 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] removing excerpt from single.php’ is closed to new replies.
Skip to toolbar