WordPress.org

Forums

Removing Dead Space on Bottom of Page (16 posts)

  1. harpagonpress
    Member
    Posted 1 year ago #

    I'm attempting to remove the dead space that has been created on the bottom of the page -- ever since I disabled the comments section. Does anyone have advice? Here's a photo:

    http://outisiv.brinkster.net/screenshot-01.png

  2. 1. We can't see the image as it returns a 403 error.

    2. An image doesn't help when trying to solve HTML/CSS related issues.

    All I can say is use your browser's developer tools to adjust the padding/margin on the element.

  3. Aaron "The Monkey" Leal
    Member
    Posted 1 year ago #

    Hi Harp,

    The PNG is not working therefore I cannot see what to remove.

    Also as a good moderator says.

    Do not edit the theme itself. First create a child theme for your changes. Or install a custom CSS plugin.

    Can you repost the link please?

  4. harpagonpress
    Member
    Posted 1 year ago #

    1. The look works for all three of my devices. Don't know what the issue is on your end.

    2. I figured that it would provide a good visual aid.

    I've thought about adjusting the padding or margin. I'm looking for where I should do this in the CSS, as I'm using a child. Thanks.

  5. Aaron "The Monkey" Leal
    Member
    Posted 1 year ago #

    Yes, you are correct it is usually the padding issue.

  6. harpagonpress
    Member
    Posted 1 year ago #

    Aaron, thanks for the response. Here's the photo again, hopefully on a working link. -- http://harpagonpress.com/?p=743

    Please let me know if you have any workable suggestions. Thanks again.

  7. harpagonpress
    Member
    Posted 1 year ago #

    I'm attempting to see what margin/padding I need to reduce? No idea.

  8. Aaron "The Monkey" Leal
    Member
    Posted 1 year ago #

    Hey Harp,
    I was looking at your website today, and I noticed the really good security :-) good job! But around this time that I am messaging you did you edit something, because I found the code and then now its gone ha-ha. Thanks, Aaron.

  9. Aaron "The Monkey" Leal
    Member
    Posted 1 year ago #

    Hey Harp,
    These are what you should enter into the Simple CSS editor or the Child theme, then you are good to go :-).

    If you ever need anything you know where to find me. :-).
    Thanks, Aaron.

    footer[role="contentinfo"] {
     margin-top:0;
    }
    
    .site-content article {
     padding-bottom: 0rem;
    }
    
    footer.entry-meta {
     margin-top: 0rem;
    }
    
    .site-content article {
     padding-bottom: 0rem;
    }
  10. harpagonpress
    Member
    Posted 1 year ago #

    Thanks, Aaron. The dead space is the bottom has certainly been reduced. Is there some way to completely remove that horizontal line on the bottom, however?

    I noticed that you listed the following two times:

    .site-content article {
    padding-bottom: 0rem;
    }

    Are there two things I need to change or was this an error?

    Thanks Aaron, I appreciate it.

    - Harp

  11. harpagonpress
    Member
    Posted 1 year ago #

    *dead space on the bottom has certainly been reduced.

  12. Aaron "The Monkey" Leal
    Member
    Posted 1 year ago #

    Hey Harp,

    I am so sorry I have not been able to get into contact with you, but here is your answers.

    1.) Yes it was an error I apologize.

    2.) To remove the horizontal line enter this information into the CSS editor.

    footer[role="contentinfo"] {
     border-top: none;
    }

    I hope this helps :-).

    Thanks,
    Aaron.

  13. harpagonpress
    Member
    Posted 1 year ago #

    Since I put in a small text widget on the bottom, the issue with the dead space has arisen again. Does anyone have any pointers on how to remove this and make it more tight?

    The Web site is as follows. You can probably see the issue if you scroll down the footer -- http://harpagonpress.com/

    Thanks!

  14. harpagonpress
    Member
    Posted 1 year ago #

    Thanks Aaron. I'll give it a try and let you know. Appreciate the help once again.

  15. harpagonpress
    Member
    Posted 1 year ago #

    Changed the value to none, but the horiztonal line is there for some reason. Also refreshed the cache; no change, it seems.

  16. harpagonpress
    Member
    Posted 1 year ago #

    I thought about changing the value to 0, but that didn't work either. Suggestions?

Topic Closed

This topic has been closed to new replies.

About this Topic