Support » Plugin: WPSSO Schema JSON-LD Markup » Removing comments from structured data

  • Resolved stuartmasson

    (@stuartmasson)


    Hi JS, hope you’re well.

    We’re gradually updating our schema site-wide to implement all the features of your Core and JSON-LD Markup premium plugins, and have come across an issue I can’t seem to solve.

    Some of our articles (like the one below) have more than 1,000+ comments, usually questions from readers that I have answered. But when I run a rich results test, all of the data shown are the comments rather than the article copy/description/title/author, etc.

    Is it possible to disable the comments from showing in the schema or otherwise prioritising the article content rather than the comments?

    Many thanks,

    stuart

    • This topic was modified 2 months, 3 weeks ago by stuartmasson.
    • This topic was modified 2 months, 3 weeks ago by stuartmasson.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author JS Morisset

    (@jsmoriss)

    The content is a Schema Article and the comment property is used to add comments about the Article content. I’ve added paging of comments in the next version of WPSSO Core along with a new WPSSO_SCHEMA_COMMENTS_MAX constant to limit comments (when paging is not enabled). See here for more info: https://wordpress.org/plugins/wpsso/#developers

    js.

    Thread Starter stuartmasson

    (@stuartmasson)

    Great, many thanks JS.

    Your plugins are so configurable it makes my head spin! Really appreciate your prompt support responses as well. Have left a five-star plugin review, but only because I couldn’t score it higher 🙂

    Plugin Author JS Morisset

    (@jsmoriss)

    Thanks!

    BTW, you can download the latest Development version here: https://wordpress.org/plugins/wpsso/advanced/

    And if you’re a Premium user, see the Changelog for info on how to select the Development branch for plugin updates.

    js.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.