Support » Fixing WordPress » Removing "comments are closed" text

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hello!

    The fifth line from the bottom of the code you pasted appears to be the culprit:
    <p class="nocomments"><?php _e( 'Comments are closed.', 'mantra' ); ?></p>

    If you replace the “Comments are closed” text with nothing, i.e.
    <p class="nocomments"><?php _e( '', 'mantra' ); ?></p>

    You should be fine! Or you can remove the entire line to also remove the (now) empty paragraph.

    Hope that helps 🙂

    Thank you, that worked perfectly 🙂

    Apologies for the code posting – hadn’t remembered that bit of the guidelines 🙁

    My pleasure, glad it worked for you 🙂

    I just did the same edit as you suggested to judetheobscure in the Mantra theme and it worked for the first browse, then after going away from the site and coming back, the text is back. It’s not a cache issue with the browser but where else could that text be invoked? I’ve searched the entire directory of the installation but that’s the only place (in comments.php)
    that it was.

    Hi mapperboy, hmmm… that’s strange. Are you certain it’s not a cache issue? Remembering that caching can occur in your WordPress install if you have a caching plugin, but also in your browser.

    Have you tried clearing your browser cache as well as the plugin cache (if you have one installed)?

    Got the official solution from the guys at Cryout Creations.
    There’s actually a setting in the Theme Settings->Graphics dashboard which is a pull-down with four options for controlling the “Comments are closed.” text. The options are Show, Hide in Posts, Hide in Pages, Hide Everywhere.
    Not sure if the previous hard code fixes worked for an older version of the Theme, the one I’m currently using is ver 1.74.
    Something sure is overriding those line edits/removals in comments.php in my installation. Not browser cache, not WordPress site cache. I haven’t drilled into it too deep with Firebug yet. I did try to do an element inspect in DW CS5.5 but I couldn’t get it to show me the php-echo statements which must be building the page.

    Thanks mapperboy, I would never have found this. Any luck removing the new “Navigation” bar that came with the new update?

    Hi angler80,
    I haven’t upgraded my various WordPress sites to Mantra ver yet.
    What position is this new Navigation bar ? Just below the banner?
    I looked at the ‘preview’ of on the Cryout Creations site and the rounded upper corner tabs directly below the banner (I think those are what you are referring to) look exactly like the version 1.7.5 that I’m currently using.
    But perhaps there is another nav bar you are referring to?
    Let me know the details and I’ll try to help.



    Thanks! japh
    it work for me.
    but i have another problem i have create a dynamic page to my theme. but when i am going to write text in it, the text reappear in my theme out of this page. i mean the text came twice in other part of site.
    hope any one help me,,,,,,,,,,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Removing "comments are closed" text’ is closed to new replies.