Support » Fixing WordPress » Removing borders from image links

  • Resolved wddr

    (@wddr)


    If you take a look at my site:

    http://no-retro.com/home

    using Firefox or IE, you’ll see a black border around the feed button, the same thing happens to any images that contain links. Safari and Opera don’t display these borders.

    I’ve searched the forum using the search words “image, link, border” and read the posts that seem relevant. I’ve been through all my CSS but there’s nothing I can see. I’ve also tried putting img a { border: none; } in places that seemed like a good guess, but no success.

    Any suggestions? Does this seem like a CSS problem or a browser issue? Thanks in advance for any help…

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Try adding this in your CSS:

    a img {
    border: 0;
    }

    Also, your CSS contains lines commented out by adding // in front of them. This is not a valid way to comment something out in CSS. CSS only understands /* comments like this */. Just so you know.

    you’ve got the tag backwards try a img { border: none;}

    Jeez… Thanks guys, I’ve been puzzling over that for days. Worked first time

    Hi.. I was looking through the .CSS file and found and changed the following line.

    .post a img {border: 0px solid #000;}
    .post a:hover img {border-color: #CCC;}

    The px size was 4 and the color was #DDD, I changed them to 0 and then #00 and it worked perfectly..

    I hope this helps someone..

    Cheers,
    Dave

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Removing borders from image links’ is closed to new replies.