Support » Theme: Virtue » Removing 'author','category' information.

  • Resolved flicker91


    I want to remove the ‘published by’ and ‘posted in’ information from the posts. I can’t find the lines to comment in functions.php. What do I need to do?

Viewing 8 replies - 1 through 8 (of 8 total)
  • This is part of your theme’s lay-out and so you find it in the template files, not in function.php.

    You can either comment them out in your proper template file(s) in your child theme. Or you can use CSS to not to display them on the page.

    You might post a link to your site for more specific support.

    Theme Author Kadence Themes


    If you are looking to do this I would consider making a child theme as code will need to be removed out of 5 or so files.

    Kadence Themes

    Theme Author Kadence Themes


    Removing the author info is now an option in version 1.5.3

    Kadence Themes

    Hi thanks for the new feature. I needed to implement it at the time that I posted on the forum. I added this in Custom CSS and it worked.


    This is the link to the site in case you want to see it work:

    Hi there

    I’m JUST starting my website and I wanted to remove the published in- and posted by- icons on the posts, like flicker91 did. FYI I do content updates on WP (Responsive child theme) at work but I’m a total beginner at setting up a site. I saw that adding that Custom CSS worked on flicker91’s site so I thought I’d try it (copied & pasted).

    I ended up with NO featured image, and I still have the icons I was trying to remove. The posts are full width now as well, instead of in nice little columns.

    I’ve tried everything I can think of. I deleted and reinstalled the theme, deleted my plugins, deleted my cookies. I did Options Reset in Advanced Settings. I went into the database to try to search for the code I entered but couldn’t find it, and I deleted my 10 or so most recent _posts files (obviously getting desperate here). I asked my software developer boyfriend with over 10 years experience as a professional programmer to look at it, but he’s a “back end guy” with zero WordPress/CSS experience so he couldn’t figure it out either.

    Then I deleted the theme again and reinstalled it again. And pulled up the site in an incognito window. I tried Twenty Twelve and I’m not familiar with that theme BUT I’m pretty sure the featured image was working with it.

    I suppose it’s possible that the css I added didn’t create the problem but it was timed exactly. It has occurred to me I could try to delete the database entirely but… yikes.

    I really like the theme and chose it because I loved how helpful the support seemed. Please help!

    I’ve switched the site back to Virtue, and activated the Virtue Toolkit plugin. Thanks in advance! 🙂
    (I use A Small Orange for hosting)

    P.S. I did not choose that avatar.

    If it is an option in version 1.5.3, then use that. I think the developers of the theme know what they are doing better than I do.

    As for the columns, I changed those as well, by adding a few lines in custom CSS. I am not a coder, but I have a general idea about how these things work, which is why I was willing to make a few changes of my own. Which also means that I am willing to take responsibility if the site breaks in between, because of my ignorance. I’d gladly share the changes I made, but maybe you could check out themes that give you an option to alter the column width (I assure you there are themes like those as well).

    Edit: I saw your website, and your subhedding is not hidden (you can see this option by inspecting the element (right click on the post to see this)). Might be something to do with the child theme, but you don’t need a child theme to add lines in Custom CSS. I am not sure what you did right or wrong. Also this might sound silly but have you set a feaured image for the post? There is an option on the right side of the page? Just confirming.

    Theme Author Kadence Themes


    Hey jssc29,
    You post don’t have featured images showing because you haven’t set the post summery option in the post. You need to set it to portrait image.

    You saw it before likely because you had enabled the latest posts module in theme options. Home layout.

    As for adding css to remove the author category etc. The code that flicker91 used works just fine. Or you could do

    .subhead {display:none;}

    Either way you want to add that to the custom css box in advanced settings in the theme options.

    I recommend you take a look at this tutorial on setting up a home page:

    As well as the theme docs:

    Hope that helps.
    Kadence Themes

    Wow you rock.

    I have no idea how I changed it for the worse, but your fixes corrected it. Definitely going to check out the tutorial.

    If I get serious about this website thing in the future I’m going to you guys for a premium theme.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Removing 'author','category' information.’ is closed to new replies.