Support » Plugin: WooCommerce » Removing an item from cart results in missing cart

  • Resolved JamesKoussertari

    (@jameskoussertari)


    Hi, whenever I try to remove an item from the cart using the little red cross the entire cart just disappears from the HTML markup. I have to refresh the page in order to get the cart back.

    I know this is a theme conflict of some sort, as I have switched themes and the problem goes away. However I have gone through and deactivated pretty much everything in my theme one by one and I can’t pinpoint what is causing it.

    Any ideas why this is happening or common issues within custom themes that could be the culprit?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter JamesKoussertari

    (@jameskoussertari)

    Hi,

    After doing some more digging and checking websites where the cart does work, I think I have an idea why it’s happening.

    It seems the XHR request is wrong and redirecting to /?removed_item=1 which returns a 302.

    I think it should be /cart?removed_item=1

    See screenshot which may help.
    https://ibb.co/K740Q4p

    Any ideas why this is happening?

    Thanks

    Thread Starter JamesKoussertari

    (@jameskoussertari)

    I managed to figure this out on my own in the end.

    In my header.php I had this meta tag:

    <meta name=”referrer” content=”origin”>

    Somehow this was interfering with the ajax header location.

    Changing it to this fixed the problem:

    <meta name=”referrer” content=”origin-when-crossorigin”>

    Hope this helps someone else one day.

    @jameskoussertari thank you! you spared me hours of debugging.
    For me this happened because I have vimeography on my website which outputs this tag for restriced videos.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.