• Resolved powcom

    (@powcom)


    I’m a big fan of PageFrog – You’re doing a great job helping us through this AMP new territory.

    I’ve had it installed for a while and now have ~3k AMP pages being reported in Webmaster Tools.

    One thing that throws an AMP validation error is mp3 files entered in to posts, that usually display the embedded audio player to play audio/podcasts.

    I was wondering are you converting from audio tags to amp-audio [https://www.ampproject.org/docs/reference/extended/amp-audio.html]?

    If so, could you let us know the best way to alter our posts 1) just use the full path to the mp3, or 2) use the [audio] shortcode?

    https://wordpress.org/plugins/pagefrog/

Viewing 2 replies - 1 through 2 (of 2 total)
  • After some experimenting this morning, I’ve found:-

    If you’re serving your audio from http, nor https, you cannot use the usual ‘just stick in the mp3’s URL/path in a post’.

    To get it working you have to use [audio src="audio-source.mp3"] AND you have to put the URL/path to the audio audio file _without_ the http.

    example
    [audio src="//example.com/audio/audio-source.mp3"]
    not
    [audio src="http://example.com/audio/audio-source.mp3"]

    Hope this helps all of you who are on this AMP journey 🙂

    Plugin Author pagefrog

    (@pagefrog)

    Hi powcom,

    I’m so sorry for the delayed response! Since AMP rolled out I’ve been receiving hundreds (maybe thousands!) of questions and emails. I’m doing my best to keep up!

    AMP requires all files to be linked through a relative path or https. If you use http and not https, AMP will throw an error.

    For all the other readers here, if you have a plugin that’s stripping out the https from your file paths, then be sure to change that or disable it. AMP requires that all files be linked through https.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.