Support » Plugin: Disable and Remove Google Fonts » Removes the visible font but not all calls to fonts.googleapis.com, Hemingway

  • Resolved carstengermer

    (@carstengermer)


    Hello everyone,
    I just installed the plugin to comply with recent decisions with data protection (DSGVO).
    The author of the Hemingway gave me the hint to try out your plugin.

    Having it installed and activated changes the visible font but the one call to google that I can readily identify remains in the pages source.

    <link rel=’stylesheet’ id=’hemingway_googleFonts-css’ href=’//fonts.googleapis.com/css?family=Lato%3A400%2C700%2C400italic%2C700italic%7CRaleway%3A400%2C700′ type=’text/css’ media=’all’ />

    Is there anything I can do to get the plugin to remove that?
    Thanks in advance! /Carsten

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Danny Cooper

    (@dannycooper)

    Hi @carstengermer,

    I’ve just released a new version (1.3.7) that should work with Hemingway.

    Let me know how it goes.

    Thanks
    Daniel

    Thread Starter carstengermer

    (@carstengermer)

    Hey @dannycooper,
    Updated and unfortunately it doesn’t seem to solve this.
    Again, the visual fonts are removed. Of course I’m unsure if the plugin is even supposed to alter the things deeper(?) in the stylesheets.

    There are still calls to fonts.googleapis and fonts.gstatic. I uploaded a screen from Networkanalysis in Firefox.
    https://www.die-partei-hamburg.de/wp-content/Screenshot-2022-02-22-112519.png

    Thanks for your help and please let me know if your plugin isn’t even supposed to block these calls!
    Cheers /Carsten

    Plugin Author Danny Cooper

    (@dannycooper)

    Hi @carstengermer

    What is this file? <link rel='stylesheet' id='so-css-hemingway-css' href='https://www.die-partei-hamburg.de/wp-content/so-css/so-css-hemingway.css?ver=1551440429' type='text/css' media='all' />

    It’s located outside the theme directory, is it some kind of optimization/caching?

    Theme directory: https://www.die-partei-hamburg.de/wp-content/themes/hemingway
    File in question: https://www.die-partei-hamburg.de/wp-content/so-css/so-css-hemingway.css

    Thread Starter carstengermer

    (@carstengermer)

    To the best of my knowledge that is a file that belongs to the SiteOrigin plugin. Something I am trying to get also get rid of but can’t really right away due to layout/design issues *rolleyes*

    Let me have a quick check…
    Well, yes, I had the “SiteOrigin CSS” plugin still active bc of design.
    When I disable _that_ and have “Disable/Remove Google Fonts” active there are no calls to big G left, whatsoever.

    As I see it SO writes a mixnmatch-CSS that joins its stuff in to the theme that is active at the current time. For us SO is kinda unnecessary now with the block editor…

    Thanks for the hint! This solves my question and leaves me with the task of getting rid of SO completely 😉

    Cheers! /Carsten
    (solved)

    Hello,

    I have the same problem with the TRUCKING theme, bought from ENVATO. I installed the REMOVE plugin but it still shows the link to Google.
    How can I remove that? Is there a CSS I can use? I use SUPER FORMS as well on the website. Maybe that is the problem. I can´t change the font there.

    I would be very glad for any help.

    Best regards
    Lutz
    ################################

    See code below

    <link rel="pingback" href="https://fki-service.de/xmlrpc.php" />
    
            <title>FEHR – KNETTENBRECH IndustrieService GmbH & Co KG – Ihr zuverlässiger Entsorgungspartner</title>
                            <script>
                                /* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                                if ( typeof WebFontConfig === "undefined" ) {
                                    WebFontConfig = new Object();
                                }
                                WebFontConfig['google'] = {families: ['Open+Sans', 'Raleway:800,600']};
    
                                (function() {
                                    var wf = document.createElement( 'script' );
                                    wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                    wf.type = 'text/javascript';
                                    wf.async = 'true';
                                    var s = document.getElementsByTagName( 'script' )[0];
                                    s.parentNode.insertBefore( wf, s );
                                })();
                            </script>
    Plugin Author Danny Cooper

    (@dannycooper)

    Hi Lutz,

    Which file/folder is that code located in?

    Hi Danny,
    thank you for your reply.
    Honestly, I don´t know. I copied this code from the top area of the startpage of the website. https://fki-service.de

    But where it is written, in which PHP, hmmm, I don´t know. I have not found anything where I can disable the google connection inside the theme.

    Best regards
    Lutz

    Plugin Author Danny Cooper

    (@dannycooper)

    Unfortunately it sounds like the code is hard-coded into the theme and there is no way to remove it without editing the theme files directly.

    Hi Danny,

    thanks so much for your support. By the way, I have used your plugin on two other pages and there it works fine.

    One more question, what do you think which file I have to alter? Do I look for a PHP or more likely for a CSS?

    Best regards
    Lutz

    Plugin Author Danny Cooper

    (@dannycooper)

    It will definitely be in a PHP file. If you have an app that can search for text strings you should be able to find it quite easily by searching for ‘WebFontConfig’.

    Hi Danny,
    thank you for your answer. I will have a look into that. At the moment I have the fonts back to the browserfonts and in combination with your plugin it is ok. The code in gone.
    But I will investigate this further. Thank you for the hint.
    Best regards
    Lutz

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.