Support » Plugin: Theme My Login » Remove/Disable "Remember Me" & "Lost Password"

Viewing 6 replies - 1 through 6 (of 6 total)
  • you can simply do it by modifying form-login.php
    steps:
    1- copy login-form.php file from TML plugin folder and paste it into your theme folder

    2- open login-form.php in your theme folder with any editor to edit it according to followings

    to remove ‘Remember me’ section:
    2-a) find <p class="forgetmenot">
    2-b) delete until you see </p>
    to remove ‘Lost Passwords’:
    2-a)find <?php $template->the_action_links( array( 'login' => false ) ); ?> and delete it
    2-b) copy below instead of it:

    <?php if ( $action_links = $template->get_action_links(   $args ) ) {
    	echo '<ul class="tml-action-links">' . "\n";
    	foreach ( (array) $action_links as $link ) {
    		if($link['title'] != 'Lost Password')
    			echo '<li class= col-md-3><a href="' . esc_url( $link['url'] ) . '" rel="nofollow">' . esc_html( $link['title'] ) . '</a></li>';
    
    	}
    	echo '<ul>';
    } ?>

    4- save the file and close it.

    This is great, but it still shows “Remember Me” in the sidebar widget.

    Also, there is not “Log In” link on the log in page which is not needed.

    Please advise.

    It should’ve worked! if there’s a way I can see your code in file, maybe I will help you more.

    Plugin Author Jeff Farthing

    (@jfarthing84)

    As @gygulance mentioned, copy the template and edit it. To remove the Lost Password link, simply edit the Login page’s shortcode:

    [theme-my-login show_pass_link=0]

    “Remember Me” is not gone.

    However, there is a “Log In” link showing up in the widget even though I unchecked that box in the settings.

    This is the homepage.

    Plugin Author Jeff Farthing

    (@jfarthing84)

    If you used the code from @gygulance above, that is why.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Remove/Disable "Remember Me" & "Lost Password"’ is closed to new replies.