Support » Plugin: Temporary Login Without Password » Remove your JS & CSS from all admin pages

  • Resolved Alex Kladov

    (@prowebassist)


    Hi,

    Your plugin is causing compatibility issues with a popular premium membership plugin
    UMP (Ultimate Membership Pro).

    Can you please make sure that you load your scripts & styles **ONLY** on your plugin’s admin pages?

    In particular I am talking about the /temporary-login-without-password/includes/feedback/assets/js/sweetalert2.min.js script. It’s loading on all admin pages & it’s preventing UMP from being able to run a Delete user function. Not sure what else it might be affecting. Either way, all Temporary Login Without Password scripts should ONLY be loaded on your plugin’s admin pages, otherwise it can cause all sorts of compatibility problems, not just with UMP.

    Here is a screenshot of what happens, when Delete button is clicked under a user on a UMP admin page:

    UMP and Temporary Login Without Password compatibility issue

    Regards,
    Alex

Viewing 3 replies - 1 through 3 (of 3 total)
  • Alex Kladov

    (@prowebassist)

    Also, it’s not important, but I noticed that the sweetalert2.min.js file says it’s min, but it’s not actually minified..

    Plugin Contributor Malay Ladu

    (@malayladu)

    Hi Alex,

    Thanks for pointing this out.

    We have fixed this issue and released a new version 1.6.0.

    Please upgrade to and let us know how it goes.

    Alex Kladov

    (@prowebassist)

    Hi @malayladu,

    Awesome! Thank you so much for releasing a patch so quickly.

    Regards,
    Alex

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.