Support » Fixing WordPress » Remove /wp/ from the url

  • Resolved warringtonscott


    I stupidly set up the WP siteurl as

    Mistakenly I thought it would be easy to edit the sites URL and/or physically move files within FTP to change this.

    The old site is

    When I go to General Settings there is no ability to edit site to plain old
    – Site title and tagline – are the first lines in the General Settings.
    Having read and read threads and become utterly confused, can anyone give me a dead simple, foolproof process to sort this.
    Many thanks, ws.

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi


    Forum Moderator

    Thanks for your prompt reply esmi,

    I had been looking through this page before but I fell at the first instruction because
    when I go to the General panel, I have no box for ‘Site address’ or ‘WP address'(URL)

    So I can’t change the address to the root directory’s URL.
    I feel I can’t do anything until I resolve this step.

    Thanks for any help, ws.



    Forum Moderator

    I have no box for ‘Site address’ or ‘WP address'(URL)

    Try looking again.

    Also your site is still running at

    Hi esmi,
    With thanks,

    Here is a screenshot I’ve posted on of pencilkit’s general settings page

    I can see editable settings in the dougiescott general settings, so I know where they ideally should be.
    Thanks for your trouble ws



    Forum Moderator

    Who installed WordPress on this site and when?

    It was installed a couple of weeks ago by a colleague, and as far as I’m aware, it was all fine to upload. We certainly didn’t meddle with anything we shouldn’t have (too stupid!)
    I had tried myself earlier but it would not fully install.

    I think it was uploaded through I believe as part of
    Hope this sheds some light,
    Many thanks, ws



    Forum Moderator

    Are you using a role management plugin?

    How many users are registered for this site? If it was installed by someone else, they’re probably the default admin. Is it possible that your login username has not been given administrative permissions? The admin may need to assign your username an admin role as well.



    Forum Moderator

    An editor user wouldn’t have access to the Plugins menu – which the OP does seem to have.

    Esmi, Sorry – a role management plugin? Please explain thank you.

    Lettergrade, Both my colleague and I as users are ‘super’ admin.
    I have gone in through her name too and it is the same issue. With thanks ws

    Hi and thanks for thoughts and help so far,

    I’m beginning to see that maybe it’s because this site is part of a WP multisite that we have these problems – not being able to change URL in General Settings.

    I was pointed towards this page
    and from there some directions to resolve this issues for a multisite but it does not look nice to do!

    Q: As the site is hardly started do you think it would be simpler to reinstall WP with the original basic URL? –

    Thank you in anticipation, ws

    I tried all the solutions on the moving WP multisite page to no avail.
    There was no easy answer and in the end a developer helped me.
    We deleted the WP multisite installation and reinstalled a single WP site, at his suggestion. By reinstalling we could start afresh with the originally intended title.
    I wish there had been a simpler answer – but there you have it, and brings this topic to – well not exactly resolved – but a conclusion.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Remove /wp/ from the url’ is closed to new replies.