Support » Fixing WordPress » Remove "This entry was posted in by . Bookmark"

  • I’m trying to edit the text that appears at the bottom of each post in my Theme called Twenty Eleven

    At the bottom of each post there is an annoying text that reads…

    “This entry was posted in Art, Mil, Street, Style by samuraicc. Bookmark the permalink.”

    I want to delete “This entry was posted in” so that just the catagories show.

    I also want to delete “By <author>”

    and I really want to delete “Bookmark the permalink”

    help please.. i cant find the code anywhere in the HTML files. Ive removed my whole entire footer but all that does is remove the white background.. the text stays..

Viewing 9 replies - 1 through 9 (of 9 total)
  • I guess i should post my website so you can see the issue.

    Look right above “Comments are closed” to see my issue.

    You should read up on Child Themes ( before making any changes to the Twentyeleven theme so your customizations don’t get overwritten at a later date.

    Once you have the child theme created, look inside content.single.php and modify the text found below the <footer class="entry-meta"> line.

    ive messed it up…

    now my posts look like this!

    how do i reset the content.single.php line to Default??

    can someone please write a more detailed way on how to change exactly what i want to change? I deleted all the text in the footer and it took away everything. It looked nice, but what I want is for the catagories to stay, the author to stay, and everything else to go..

    No text that says “By” SamuraiCC.. just the authors name..

    so i deleted all the text inside the codes that say Posted By… or Bookmark this post

    and then I got that error

    If you made a child theme, just delete the file you made and start over.



    Forum Moderator

    That looks like someone has been editing the Twenty Eleven theme – which is a major “no, no”. Re-upload a fresh, unpacked, copy of the Twenty Eleven folder to wp-content/themes using FTP or whatever file management application your host provides.

    Then create a child theme for your changes.

    Ok i found the default content.single.php on the internet, and i reset the html to default so the error is no longer there…

    I just want to change “This entry was posted in History, Metaphysics, Military Science, Space, UFO Research, Universal Registry by samuraicc. Bookmark the permalink.

    And make it say… History, Metaphysics, Military Science, Space, UFO Research, Universal Registry



    Forum Moderator

    Stop editing the Twenty Eleven theme. It is the default WordPress theme and having access to an unedited version of the theme is vital when dealing with a range of site issues. Create a child theme for your changes.

    Ok ive fixed my issue. It now looks perfect.

    I have not installed a Child Theme.

    The reason being, I don’t want to have to go through all of my current edits all over again.

    Can someone please explain why I need a child theme? I wont have any vital site issues because all im using this for is a simple wordpress blog and ive never had any site issues in the past.

    I also dont want to install it because after reading the first few paragraphs of that page, I was lost.

    If I install it, will all my current HTML edits be lost?



    Forum Moderator

    If you screw up one of your edits and the entire site goes pear-shaped, we have no way of getting your site back up & running again without over-writing all of your changes with a fresh copy of the original Twenty Eleven theme. And those edits will be lost forever. Full stop.

    Do yourself a favour. Don’t edit the Twenty Eleven theme.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Remove "This entry was posted in by . Bookmark"’ is closed to new replies.