Support » Plugin: WooCommerce PayPal Payments » Remove “Ship to billing address” from checkout

  • Resolved irmscher9

    (@irmscher9)


    Hey

    I would like to somehow disable “Ship to billing address” option with checkbox in the PayPal checkout stage when you press “Debit or Credit Card” button. Here’s the image.

    Why? Because it’s confusing for client when it’s asked to enter his/her address 3 times in a row. I would like Woocommerce fields to serve Shipping address purpose and the drop-down PayPal menu only for billing address purpose.

    I tried to remove the thing with Custom CSS but it seem won’t work since it’s a dynamically loaded form plugin? Not sure, can someone please shed some light on it.

    Cheers 🙂

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Joost van de Vijver

    (@joostvandevijver)

    Hello @irmscher9

    The “ship to billing address” option you are talking about is generated by PayPal and is not controlled by our plugin.

    PayPal decides on the basis of several factors which payment flow is initiated for the customer after clicking the button.
    Included in these factors could be: The user location, user language, eventual PayPal cookies stored on the computer, and many more.
    Some users may be presented with the inline smart fields, while some others may be presented with the checkout flow through the popup with a forced PayPal registration.
    You can find more information about the standard card fields in the PayPal documentation.
    https://developer.paypal.com/docs/checkout/integration-features/standard-card-fields/
    What payment flow is initiated through the default credit card button cannot be influenced in the plugin.

    The best thing you can do to prevent users from having to enter these details again for credit card payments is to activate the PayPal Card Processing:
    https://docs.woocommerce.com/document/woocommerce-paypal-payments/#section-8

    I hope this answers your question.

    Kind regards,
    Joost

    Plugin Support Joost van de Vijver

    (@joostvandevijver)

    Since we haven’t heard back from you, I’m going to mark it as resolved.
    In case you’re still having problems, feel free to let us know!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.