Support » Plugins and Hacks » Remove "search provided by Store Locator Plus" Below Map

Remove "search provided by Store Locator Plus" Below Map

  • kentragik


    I’d like to remove the message/link “search provided by Store Locator Plus” below the map. I’m a Pro Pack AND Store Pages user. This suddenly appeared when I upgraded to version SLPlus 3.6.

    Also, an open piece of code also appears “class=’sl_footer’
    style=’display:none;’ >” underneath the map.

    I assume both of these pieces can be edited in the same file? Just can’t seem to find it.


Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author Store Locator Plus


    Please provide your site URL.

    There is a checkbox to remove credits on the map settings page. It seems like you have that marked off but for some reason your installation is not processing that section of code properly with SLP v3.6.

    SLP 3.6 does use a new search and results form processing engine to provide hooks for third party add-ons. Some versions of PHP5 do not play well with the new hooks. Thought we caught them all in testing, but possibly something still remains that needs to be fixed.



    Hi, Thanks for your response! Here’s the URL: http://monkeybargym.com/locations/

    Plugin Author Store Locator Plus


    Version 3.6 has a problem with sites not using English as the primary langauge. The PHP function used to create the search page segments (search form, map ,results) is translating ” to &#8217 before it is rendered.

    I am working on a patch now.

    Plugin Author Store Locator Plus


    Go here and “purchase” SLP.

    With your purchase you will create an account where you can download the beta copies before they are published.

    I think SLP v3.6.1 beta will fix this issue. I have no idea why the WordPress translation of ‘ to &#3617 in the HTML output suddenly kicked in. The line before the broken code is fine. The next line breaks and there is no code just HTML between the two.

    Very odd. Still guessing as I cannot reproduce this and can’t figure out what triggers WordPress to turn on “quote translation”. I thought it was the locale setting but that is not causing the problem on my server. :/

    Plugin Author Store Locator Plus


    Anyone that wishes to try 3.6.1 RC3 you can go to http://www.charlestonsw.com and “purchase” (it is free) Store Locator Plus. When you do this you will get a download link and/or can download from your account (login on bottom right) and get the latest 3.6.1 RC3 zip file.

    Login to WordPress, go to plugins, deactivate/delete/upload/activate the SLP plugin.

    This is a destructive update so be sure to backup your code files. Location and setting data is retained.

    – Div code rendering under map as text versus HTML for some sites using plugins or themes with extended shortcode processing (something called “texturize”).

    – Use Location Sensor prevent map from rendering if use does not share location.

    The version I downloaded from here did not resolve the issue. The version being reported is 3.6.1

    I have it deployed here: http://mdt.11bdev.com/locations/by-location

    Plugin Author Store Locator Plus


    Are you using a ThemeForest theme by any chance? It is looking like a possible bug in their theme engine that is not honoring the “do not texturize my shortcode” settings and is wreaking havoc in SLP3.6.

    If anyone that is having this issue can send me their Themeforest theme so I can test and possibly find a workaround that would help.

    Plugin Author Store Locator Plus


    The good news – I’ve finally reproduced the error. Purchased a ThemeForest Theme (natural) and turned it on. Instant breakage. That means I can track down the issue, report it to ThemeForest and possibly write a workaround to whatever is breaking.

    The bad news – I’m on vacation with my family, stealing away a couple of hours to code while they sleep. Not sure I will find a fix before I am offline for another couple of days.

    Hi there, once you have reported the issue to ThemeForest, would you mind contacting me with the support ticket ID? I’d like to keep track and help get it resolved.

    Plugin Author Store Locator Plus


    @japh – Will do.

    I think I have a patch that may work, I need to wrap ALL output in [raw]..[/raw]. That is a horrible way to fix this as it can cause all sorts of odd things to happen on all themes that are NOT using the ThemeForest “special sauce”.

    The short less-tech version of this is that ThemeForest is forcing a call to the internal wptexturize() function AFTER shortcodes are rendered. That is NOT how that function is supposed to be used. That WordPress function has a specific filter that says “please do not process my shortcode with texturizing”.

    What that means is if I write code like this:

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button. Or just think “The Code Button is Your Friend and should be respected and used.” ]


    I can tell WordPress “leave this alone, it is not standard post content”. If I do not do that then WordPress changes the HTML to this, which is WRONG:


    It adds in HTML codes where I had soft returns in my HTML code. I added that in a LOT Of places for readability, which is why 3.6.1 “suddenly broke”.


    However simply adding a soft return in my HTML to make it more readable should NOT break anything. That is not the function of a theme and is not for a theme to decide. I told WordPress “hey, don’t format this stuff, it is code”.

    ThemeForest has a “special sauce” function that many theme developers use that is called AFTER shortcodes are rendered. Thus it completely ignores my “please don’t format this instruction”.

    In short, Theme Forest themes are saying “SCREW YOU PLUGIN DEVELOPER, I’ll format this anyway”. That sucks.

    Now I need to add a “I’m using ThemeForest or another wonky theme” setting that wraps my clean HTML in [raw]…[/raw] tags, which is NOT valid HTML nor valid WordPress code. It is “don’t let ThemeForest break my code” code. At the very least they should provide and DOCUMENT a filter that allows people to tell that function “please don’t touch this”. Even smarter… re-process the shortcode and script fitlers that are standard WordPress fodor. Even smart still… do NOT re-texturize content AFTER the shortcodes and scripts are rendered, since WordPress clearly does not expect nor want you to do this.


    Enough with the rant. I know what is breaking, why it breaks, and how to get around the shortcomings of the themes. Now I need to come up with a creative way to provide an easy end-user fix without breaking 10,000 other installations that are working right now. That is going to take a week or so.

    Back to vacation… I have a beer to finish and family to take to the theme parks in the morning. 🙂

    Plugin Author Store Locator Plus


    Oh great – WordPress posts strips out SOME HTML tags so my “wrong” and “right” code example look the same. What it SHOULD say is that the re-processed table tag has break < br / > codes all over the place, basically invalid HTML syntax. Then all hell breaks loose.

    Thanks for the comprehensive feedback.

    Just to clarify, this isn’t something ThemeForest is doing, but it is something a lot of our authors seem to have started doing at some point. We’re actively working to discourage this now, and it should be less and less of a problem as time goes on.

    When you submit this information to Envato support, please let me know so I can ensure it gets through to the right people.

    Moderator Jan Dembowski


    Oh great – WordPress posts strips out SOME HTML tags so my “wrong” and “right” code example look the same.

    Or you could use the code button to insert the backtick character on a new line before or after your code in a post. 😉


    Just to throw in my bit as well, I’m seeing the code, as well as formatting behavior in the ThemeForest Theme I’m running (Grizzly)
    I can send you files any time, just let me know if you still need them.
    IE Display: (link)
    Chrome display: (link)

    Also, if you look closely at the IE screenshot, you can see a marker between the outer two markers. This is a phantom marker, not sure where it came from, but it displays on both Chrome and IE, regardless of zoom level.

    Let me know if I can offer any more useful information to you.
    site link: http://www.new.orderapp.co

    Plugin Author Store Locator Plus


    3.6.2 should resolve the issue, wptreats_formatter() is not behaving properly but I’ve put in a patch that I think will fix this.

    @bwasson – please start a new thread for things not related to the open HTML issue

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Remove "search provided by Store Locator Plus" Below Map’ is closed to new replies.