Support » Fixing WordPress » Remove rel = “noopener noreferrer” in wordpress 4.7.4

  • Resolved richireo2016

    (@richireo2016)


    It turns out that when updating or creating a new pagefront in wordpress 4.7.4 this automatically adds to the target_black this rel = “noopener noreferrer” is there any way to disable it? Cause me problems

Viewing 15 replies - 1 through 15 (of 24 total)
  • Moderator Steve Stern

    (@sterndata)

    Another person has reported this at https://wordpress.org/support/topic/internal-links-are-suddenly-nofollow/

    Are you using the Genesis theme?

    richireo2016

    (@richireo2016)

    I do not use that simple one theme

    Only the problem appears in the wordpress version 4.7.4

    Moderator Steve Stern

    (@sterndata)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    Also, Please provide a link to a page on your site where we can see this. Thanks.

    tr3ndygirl

    (@tr3ndygirl)

    hi Steve, i have the same issue
    after update wordpress to 4.7.4–it_IT version, into link with target_blank, be automatically added this target=”_blank” rel=”noopener noreferrer”> in all article, see my blog http://tr3ndygirl.com
    Previous articles and links published in 2 past days, instead, have remained normal such as target=”_blank”>
    This bug occurs after the last wordpress update, please help me to solve it
    thanks

    tiamana

    (@tiamana)

    I have the same issue.

    When I created a new page today and set all links as nofollow the “noopener noreferrer” was added. There is no chance to delete it! It is always added again and again after having been removed…

    First time this occurred. I updated to 4.7.4 yesterday. I use theme Enfold.
    http://welt-der-vorfahren.de

    This is annoying. Please solve it – thank you!

    Ditto. This is probelm has completed stopped our referral tracking. Google analytics, and three of our link tracking plugins are failing because noopener and noreferrer are being injected into each link. It disables any sort of referrer tracking, as its supposed to. We need to disable this function. I am unable to find any documentation on the function from the 4-7-4 release two days ago. It appears to be a bug.
    Feedback on how to resolve this issue would be greatly appreciated.

    Chocolate-Covered Katie

    (@chocolate-covered-katie)

    I’ve been having the same issue and had opened a topic about it yesterday. I tried disabling plugins, but the problem (which started right after the newest WordPress update) remained.

    Inspecting the code of many other wordpress sites, I see the same thing for other sites so am thinking this is an issue related to the newest WordPress update… hopefully they know about it and are working on a fix (if it is indeed related to the update). I’m admittedly not the most tech-savvy person, but I don’t think having all of my internal links set to nofollow is ideal.

    Moderator Steve Stern

    (@sterndata)

    This is a security fix to TinyMCE, which was updated in the 4.7.4 release.

    See

    https://www.tinymce.com/docs/changelog/#version450-november232016

    https://github.com/tinymce/tinymce/issues/3177

    https://www.tinymce.com/docs/configure/content-filtering/#allow_unsafe_link_target

    It’s a security thing.

    If, after reading the above, you want to disable the new setting, you can overide it with this in your functions.php or in a plugin. It is not recommended.

    // Note that this intentionally disables a tinyMCE security feature.
    // Use of this code is NOT recommended.
    add_filter('tiny_mce_before_init','tinymce_allow_unsafe_link_target');
    function tinymce_allow_unsafe_link_target( $mceInit ) {
    	$mceInit['allow_unsafe_link_target']=true;
    	return $mceInit;
    }
    • This reply was modified 5 months, 4 weeks ago by  Steve Stern.
    • This reply was modified 5 months, 4 weeks ago by  Steve Stern.
    Chocolate-Covered Katie

    (@chocolate-covered-katie)

    Hi Steve, and thanks so much for the information. Hopefully this is not a dumb question… but why would it not be recommended to change the feature? As long as we have already set our external links to nofollow, wouldn’t it be a bad idea to leave the TinyMCE feature as-is and have our internal links be nofollow?

    Right now, the feature automatically set all of my internal links to noreferrer.

    cockpit problem. code appears to be working. thank you

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @chocolate-covered-katie This is considered to be a security improvement, thus, it is not recommended to allow external links in new tabs to have access to that information via JavaScript.

    Chocolate-Covered Katie

    (@chocolate-covered-katie)

    Hi, yes I definitely understand why it’s good for external links… My worry is that internal links are now also being labeled as nofollow.

    The internal links that open in a new tab (and I have many on old posts) are now all automatically set to noopener noreferrer. Isn’t this detrimental to a site’s SEO?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @chocolate-covered-katie The change in question is in the tinyMCE code. It doesn’t change anything that you don’t load up in the post editor. So, yea, if you edit a post, it will possibly be altered to fit with the new tinyMCE code, but posts in the database are not magically altered by WordPress to align with this.

    Also, no, this doesn’t affect SEO, it affects browser behavior. SEO is what search engines do, not what browsers do.

    Hi, i have solved with this code, putting into my functions.php

    // Note that this intentionally disables a tinyMCE security feature.
    // Use of this code is NOT recommended.
    add_filter('tiny_mce_before_init','tinymce_allow_unsafe_link_target');
    function tinymce_allow_unsafe_link_target( $mceInit ) {
    	$mceInit['allow_unsafe_link_target']=true;
    	return $mceInit;
    }

    very thanks

    Chocolate-Covered Katie

    (@chocolate-covered-katie)

    I have always heard that you should keep internal links dofollow, especially if you want those posts to do well in google search:

    https://www.labnol.org/internet/drop-nofollow-from-internal-links/14107/

    So I still don’t understand why it would be recommended to leave the new feature intact that automatically makes our internal links nofollow if they open in a new tab. I’m not trying to harp on this issue; just want to make sure I completely understand the best course of action to take in terms of whether to disable the new feature. πŸ™‚

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Remove rel = “noopener noreferrer” in wordpress 4.7.4’ is closed to new replies.