[resolved] Remove proofreading from users profile (8 posts)

  1. oldpj100
    Posted 3 years ago #

    I am trying to simplify the look of a users profile once they have registered and logged in. I have managed to remove everything I want except the proofreading. Below is what I am trying to remove. Can anyone help?

    Automatically proofread content when:

    a post or page is first published
    a post or page is updated

    English Options

    Enable proofreading for the following grammar and style rules when writing posts and pages:

    Bias Language
    Complex Phrases
    Diacritical Marks
    Double Negatives
    Hidden Verbs
    Passive Voice
    Phrases to Avoid
    Redundant Phrases

    Learn more about these options.


    The proofreader supports English, French, German, Portuguese, and Spanish. Your WPLANG value is the default proofreading language.

    Use automatically detected language to proofread posts and pages

    Ignored Phrases

    Identify words and phrases to ignore while proofreading your posts and pages:

  2. esmi
    Forum Moderator
    Posted 3 years ago #

  3. oldpj100
    Posted 3 years ago #

    thanks but none of these seem to remove the section from the users profile. Basically i want them to be able to post and see their personal info only. I have got it to do these, but the proof reading section is always there. I need this only for the contributor role.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    There is no "Proofreading" functionality/option in WordPress itself. Perhaps this is a plugin?

  5. oldpj100
    Posted 3 years ago #

    Thanks. Think it might be someting within a plugin. Not cured it comepletely, but got a way around it.
    Thanks again

  6. SouthPH
    Posted 3 years ago #

    Would you mind sharing how you fixed this? Thank you.

  7. oldpj100
    Posted 3 years ago #

    In the end i used a plug-in called peters-login-redirect.zip and just used the post page url as the destination. seems to work fine for what I want it to do!
    Hope this helps.

  8. pazzaglia
    Posted 3 years ago #

    I figured it out. It's Jetpack that jams all of that information in your user profiles.

    To remove proofreading from your and all of your subscriber's profiles...

    1. From the admin console, click on the "Jetpack" menu item.
    2. Look for the "Spelling and Grammar" box.
    3. Click on "learn more" button.
    4. The button next to "learn more" changes from "configure" to "deactivate".
    5. Click "deactivate".
    6. Breathe a sigh of relief because the user profiles look decent again.



Topic Closed

This topic has been closed to new replies.

About this Topic