Support » Plugin: Yoast SEO » Remove persistent notice "We've updated our SEO score algorithm…" in dashboard

Viewing 12 replies - 1 through 12 (of 12 total)
  • LiveNathan

    (@livenathan)

    Hey Joseph, I’m having the same problem. I keep clicking on the recalculate link, which seems to run, but then it never finishes and the notification never goes away.

    barnez

    (@pidengmor)

    Try adding this to the functions.php file of your child theme (after making a backup copy of the file first ):

    // Disable YOAST nag messages
    remove_action( 'admin_notices', array( Yoast_Notification_Center::get(), 'display_notifications' ) );
    remove_action( 'all_admin_notices', array( Yoast_Notification_Center::get(), 'display_notifications' ) );

    LiveNathan

    (@livenathan)

    But isn’t there some deeper problem if the scan doesn’t really finish and the notification persists?

    avrant

    (@avrant)

    I have the same issue. This seems to be a Yoast issue and not something we should need to punt in a functions.php file (but thank you for that fix, barnez)

    Joseph Dickson

    (@josephdickson)

    The scan reaches the end for me, but leaves the notification up. Depending on the size of my particular multi-site. In this case it’s rather large and takes several minutes freezing Firefox during the process.

    I agree with Clint, I’d have to go into functions.php for about 70 sites or create a “bypass plugin” to remove the notice and activate it on 70 sites. Both are doable but not a permanent solution.

    I suppose I could add it to my parent theme but it’s certainly a bug on Yoast’s end and I’d rather keep my theme clean of fixes for 3rd party plugins that would likely be fixed in time.

    I’ve had similar issues in the past with notifications. It’s not unique to Yoast it seems everyone wants to fly up notices when something is updated, it gets a little busy and the end user doesn’t need to see that sort of thing in their dashboards.

    jeremejazz

    (@jeremejazz)

    I am also encountering this problem and it’s driving me nuts. I’ve been closing it and it’s still there like I’d like to say “I know right!”
    What’s worse is that the process never finishes. Please add an option to disable this.

    fabiangabor

    (@fabiangabor)

    Cleared browser, Cloudflare, nginx, hhvm cache, the notice is still there. Really annoying.

    dmgonzam

    (@dmgonzam)

    chrome + Ad blocl plus + block element solved for me this stupid weird annoying… bug? or is it a feature?

    natostanco

    (@natostanco)

    just wait for an hotfix

    sem101

    (@sem101)

    just another freemium plugin hijacking WordPress admin screens. it not a bug, it bad practice. should be removed from the WordPress Repo until it resolved, regardless of popularity.

    u can try the functions.php hook by barnez or just comment the annoying nag in plugin itself, until they remove this burden.

    plugins/wordpress-seo/admin/class-admin-init.php (on or around Line 39)
    //add_action( 'admin_init', array( $this, 'recalculate_notice' ), 15 );

    (Sorry for my English)

    The latest “Version 3.0.6” seems to have fixed the problem on my end. So I’ve decided to mark this thread solved.

    G P

    (@wetapplemedia)

    I’m experiencing this too. Some notifications will dismiss, but the “Yoast SEO has been updated to version 3.4.2. Find out what’s new!” one just goes grey then pops right back up. Am I doomed to have a red dot in my side menu forever?! lol

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Remove persistent notice "We've updated our SEO score algorithm…" in dashboard’ is closed to new replies.