Support » Theme: Blocksy » Remove pages from search result

  • Resolved Sohail Ahmed

    (@indiaatnet)


    Hello,

    First of all AMAZING THEME! Very easy to use and customize the theme!

    I want to remove pages from being shown in the search result.. How do I do that?

    I tried installing different search improving plugins but nun worked.

    Is the theme not using WordPress default search?

    Please help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Theme Author creativethemeshq

    (@creativethemeshq)

    Hello @indiaatnet,
    Thank you very much for your kind words, this means a lot for us!

    Blocksy is using the default WordPress search functionality and you can customize the search through criteria from here – https://d.pr/v/n6Wdxh

    Hope this helps.

    Thread Starter Sohail Ahmed

    (@indiaatnet)

    Thank you for your quick response. Option for selecting post types is available only for header search form. But unable to modify the options for the widget search form.

    It still shows pages in the search result.

    Thread Starter Sohail Ahmed

    (@indiaatnet)

    Found a solution though!

    I used custom HTML instead of the default search widget and entered the search form HTML code along with a hidden field and now it works!

    <input type="hidden" name="post_type" value="custom_post_type">

    Is there a way to prioritize a post in search results if a specific category or tag is selected?

    • This reply was modified 8 months, 1 week ago by Sohail Ahmed.
    Theme Author creativethemeshq

    (@creativethemeshq)

    Hey @indiaatnet,
    Yes, we do not control the default WordPress widget search output.

    “Is there a way to prioritize a post in search results…” – Blocksy doesn’t have such a functionality but you could try to search for an “advanced search” plugin in WordPress plugins repository.

    Just wanted to say … this theme is amazing. Every time I ask “Can I … ?” the answer is “yes!”

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.