Feature A Page Widget
[resolved] Remove Page title link (5 posts)

  1. tobi1kanoby
    Posted 2 years ago #

    Hi Mrwweb,
    Great plugin.
    is there a way to remove the page title, leaving only the image as the link to that page?

    Have you managed or plan to solve the page title h1 issue? having multiple h1 tags on a page is not recommended in terms of SEO, can these titles be h2 or alternatively removed?



  2. Mark Root-Wiley
    Plugin Author

    Posted 2 years ago #

    Hi @toby1kanoby,

    Let's start with the removing the title question. You could do it with any of the three listed ways to modify the widget on the FAQ page (CSS, filter, template file) but I'd go with the filter. This would go in your functions.php file or a functionality plugin:

    function fpw_hide_title() {
        return null;
    add_filter( 'fpw_page_title', 'fpw_hide_title' );

    Regarding the title tags, you'll have to do this by editing the template file (Read "Override the Widget's output template." on the FAQ page). I'm contemplating a pretty significant overhaul of the plugin in the near future, and, if I do that, I'll consider allowing for this.

    However, keep in mind that this widget is written in HTML5 markup and appropriately uses the HTML5 document outline model where an <h1> tag isn't just ok, but encouraged. I would be very surprised if there's an SEO penalty for it as the widget's page title appropriately represents the primary title of a unique post.

    I get the sense that many people want to change it away from <h1> because of styling, but the title has a class specifically meant to allow for styling—.fpw-page-title—and the plugin's styles have a low specificity intentionally for overrideability. Because that's a word.

    Glad you like the widget. Please consider voting on new features and reviewing the plugin.

  3. tobi1kanoby
    Posted 2 years ago #

    Thanks a lot,
    managed to remove it through custom function plugin I've created and it worked like a charm.

    Many Thanks

  4. rusiestefan
    Posted 2 years ago #


    I paste the code from above as it is in my fuctions.php file but it doesn't work. When I try to reload the webpage it won't work. It's showing me an empty page.

    What is the problem? What do I make wrong?

    Thank you!


  5. Mark Root-Wiley
    Plugin Author

    Posted 2 years ago #

    Hi @rusiestefan.

    As a rule, please start your own thread for support requests (not just here but in all forums), particularly for ones marked "Resolved."

    If you're getting a blank screen, there must be an error in your code somewhere and you likely don't have WP_Debug set to true in your wp-config.php file (so it shows a blank screen rather than an error).

    Please set WP_Debug to true and then paste the error here.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Feature A Page Widget
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.