Support » Plugin: MojoPlug Slide Panel » Remove overflow:hidden popup

  • Resolved leonardo09

    (@leonardo09)


    Hi,

    I would like to check how can I disable/hide popup of overflow:hidden warning? It keeps appearing on Edge browser but the slide panel works well.

    The error is below:
    MojoPlug warning:This page contains element(s) blocking visibility of left side panel. To fix the problem, find and remove overflow:hidden directive(s) from parent HTML element(s).

    Regards,
    Leonardo

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author More Karvonen

    (@qumos)

    Hi Leonardo,
    That message comes from Javascript. The code thinks there’s another overlapping html element on top of it. Well, obviously in your case it makes a false assumption.

    Anyway, a quick fix in your case is to edit the Javascript file and remove error checking. You will need to open and edit this file:
    /wp-content/plugins/mojoplug-slide-panel/public/js/mojo-sp-public.js

    In rows 68 and 79 you will find the checks for both left and right panels, like this:
    if (!element.isVisible())
    alert(‘MojoPlug warning: This page contains element(s) blocking visibility of left Slide Panel. To fix the problem, find and remove overflow:hidden directive(s) from parent HTML element(s).’)

    Remove those two lines starting with “if (!element….” and “alert(…” in both locations and save the file. Refresh the browser to reload the javascript file:
    1. Right click your page
    2. View page source
    3. Find mojo-sp-public.js and click to open
    4. Right click the new screen and refresh the page. (While the code is open you can check that those lines are not there anymore.)

    That should do the trick….

    Regards, More

    Thanks for explaining this, however is there a way to do this such that it will not happen every time my client updates the plugin? Im really not sure why this is happening on my site, everything is visible. perhaps something needs to be fixed in the code? is your JavaScript taking z-index into account?

    here is the site in development in case you want to poke around. though I have turned off the warning. http://www.desmetpadres.org.php56-26.phx1-1.websitetestlink.com/

    Plugin Author More Karvonen

    (@qumos)

    Hi Colin,
    Thanks for the link, I will check this out. I will remove the message or at least add a checkbox in settings to prevent the message to pop up.

    I’ll upload a new version soon.

    Thanks for the heads up,
    More

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Remove overflow:hidden popup’ is closed to new replies.