Support » Fixing WordPress » Remove over-long excerpt

  • Resolved easilyconfused

    (@easilyconfused)


    Hi, new, recently installed site, which came with an SEO plugin. The plugin, quite rightly, tells me “The meta description is over 160 characters.”

    Yes. Except I haven’t even give it one, seems the pesky thing is forcing an ‘excerpt’ of over 300 characters.

    How to stop that? I can add and remove extras, and type in a box for the meta thingy, but I don’t seem to be able to delete, remove, banish or otherwise GET RID of this 300+ character ‘excerpt’?

    It’s not because I’ve used an overly-long 1st paragraph or anything, as that is less than 140 characters.

    Preferably without writing code or installing plugins?

Viewing 3 replies - 1 through 3 (of 3 total)
  • What plugin are you using that is causing this issue?

    Thread Starter easilyconfused

    (@easilyconfused)

    Update – I’m using the ‘Astra’ theme, and I’ve just read somewhere that even if you edit the functions.php file this thing will still force, shove, install and otherwise cram in a massive unwanted ‘excerpt’ against my will.

    More ‘resigned’ than resolved

    Thread Starter easilyconfused

    (@easilyconfused)

    Sorry, didn’t see the reply.

    The SEO plugin is ‘AIOSEO’ but I agree with it, the meta description should not be so long.

    From what I have read it’s the theme, not any plugin, forcing the excerpt issue. I figured there must be a setting somewhere, like ‘Manual meta descriptions’ checkbox or something, but seems there isn’t, at least not with this theme.

    *resigned shrug

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.