[resolved] Remove Multiple Sites/Turn off Network (11 posts)

  1. daricedotorg
    Posted 6 years ago #

    There is plenty of info on how to convert your single weblog to multiple sites. But I can't find any instructions on how to revert back to single weblog besides just making a fresh install.

    I upgraded to 3.0-beta1 and enabled multiple sites to learn more about it and see if I like it. But after a couple of weeks I miss the simplicity of one site only. I haven't created any extra sites or authors either.

    So I'm wondering is there a way to remove multiple sites option back to single without having to re-install wordpress?

  2. Take the lines out of wp-config that you added. That's pretty much it.

    You may have to put back the default .htaccess too.

  3. daricedotorg
    Posted 6 years ago #

    That was the solution!

    Remove all lines concerning MU from config.php and go back to the default .htaccess file.

  4. syssu
    Posted 6 years ago #

    I have done this a million times and it is STILL multisite. I have gotten rid of

    define( 'MULTISITE', false );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'syssu.com' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', 1 );

    There is also a define vhost one that i have to keep on there or it does not work.

    define('VHOST', 'yes');

    I also deleted and had this line but nothing

    define('WP_ALLOW_MULTISITE', false);

    As far as the .htaccess file i dont have a "default" one so i deleted everything in it but still default site.

  5. Limepuff
    Posted 5 years ago #

    I installed the network, changed my mind and changed back to the
    original wp-config.php and .htaccess, and it works fine, BUT,
    now a few weeks later when i wanting to set a new network, it just says that it already exist one and i can't create a new one/connect to the old one. Wtf?

    How do I "uninstall" the old one and get a new network?

  6. somemoinfo
    Posted 5 years ago #

    same problem as Limepuff

  7. You have to remove the database tables for the network. T hough I think if you out the lines back in the database and htaccess, it'll just turn back on with the old settings.

  8. unodewaal
    Posted 5 years ago #

    Try this:

    Remove all the lines added to wp-config.php
    Revert back to older .htaccess file or delete it and regenrate it by going to Settings > Permalinks
    Remove the two fields added to the users table that are multisite-only (deleted and spam columns).
    Remove the following tables in database (prefixed by your DB prefix which is generally wp_):
    wp_sitecategories (if you have global terms enabled)

    I found a site that has the exact SQL query, but I can't find the link again...

  9. edwinkort
    Posted 5 years ago #

    Unfortunatley, after line 2 I already have problems. :(

    Fatal error: Call to undefined function wp() in /home/bookieb/public_html/stupidnothings.com/wp-blog-header.php on line 14

    Fatal error: Call to undefined function get_option() in /home/bookieb/public_html/stupidnothings.com/wp-admin/admin.php on line 22

  10. edwinkort
    Posted 5 years ago #

    Seems to be fixed by first deleting the tables and then creating a new config file.

  11. murokoma
    Posted 5 years ago #

    Hi there,

    I tried removing the additional lines from config.php and resetting .htaccess.

    While the blog seems to be working okay, when I login as admin pretty much everything is gone - I can login and logout, but that's pretty much it.

    Did this happen to anyone who tried this as well?

Topic Closed

This topic has been closed to new replies.

About this Topic