Support » Plugin: W3 Total Cache » Remove memcached from W3TC by hand

  • Resolved danielbittar

    (@danielbittar)


    Hi there people!

    I was using Memcached in W3TC in a previous provider. Now I’m in a new provider and I’m getting the following error when trying to login to WordPress Admin Panel:

    Fatal error: Class 'Memcache' not found in /home/danielmb/public_html/auroraazul.com.br/wp-content/plugins/w3-total-cache/lib/W3/Cache/Memcached.php on line 38

    I need to disable Memcache from any configuration it is or database location but I’m not being able to do so. And I can’t login to the Admin Panel to do it there.

    How do I disbale it?

    Thanks a lot,
    Daniel Bittar.

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Two things to try:

    First, in wp-config.php, set WP_CACHE to false or add the following to your wp-config.php:
    define(‘WP_CACHE’, false);

    Second, make a backup of your database & then run this query through a database tool from your ISP (like ‘phpMyAdmin’):
    UPDATE wp_options SET option_value = ‘a:0:{}’ WHERE option_name = ‘active_plugins’;

    (for more info on that query, http://perishablepress.com/quickly-disable-or-enable-all-wordpress-plugins-via-the-database/)

    wp-config.php is probably the best method. An alternative method is to rename the W3 Total Cache configuration file. It is named w3tc-config/master.php in the current version.

    Hi there again, people!

    Well, I tried the first option and it didn’t work. However I didn’t try the second one. I just regained access to my old server, disabled the cache and did the migration again.

    Anyways thank you everyone.

    Daniel Bittar.

    Daniel

    Glad to know. Please mark this thread as resolved so that other volunteer doesn’t check on this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Remove memcached from W3TC by hand’ is closed to new replies.