Support » Fixing WordPress » Remove index.php from permalinks

  • ayaztariq786

    (@ayaztariq786)


    in permalinks option it shows https://mysite/php.index in every setting like

    https://mysite/index.php/2020/08/28/sample-post/

    Who to remove this index.php

    I’m using godaddy’s plesk | i am using shared hosting for three sites
    Problem occurs only in main site that is uder httpdocs directory.

    what i’ve tried sofar

    1. every post in this forum that is related to removing index.php
    2. i am unable to find .htaccess file (tried filezilla with force show hidden file and and other file browsers.
    3. added the .htaccess file manally (as described in some forums)
    4. edited web.config file
    5. changed permission settings.

    But every thing is not working please guide

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p

    (@t-p)

    I’m using godaddy’s plesk | i am using shared hosting for three sites
    Problem occurs only in main site that is uder httpdocs directory.

    My suggestion is to discuss with your hosting provider and ask them why it’s happening only on one of your site that is under httpdocs directory.

    JNashHawkins

    (@jnashhawkins)

    You didn’t provide a link to your site so I couldn’t look but…

    Since you are using the Plesk Control Panel and there was a web.config also, I imagine you are running WordPress on a Windows-based server. You are most likely on an IIS server also though Apache does work somewhat in Windows.

    The htaccess file isn’t used with Windows… htaccess is a Unix based construct and doesn’t work with Windows so that’s out.

    So, web.config is your options file instead… any htaccess directives available to Windows would need to be coded to work with your Windows based server’s web.config.

    Now, instead, try this…

    Go to the permalinks settings and use the custom permalink option to set up permalinks as you wish by clicking the tags… using /%postname%/ or /%year%/%monthnum%/%day%/%postname%/ is suggested.

    If that doesn’t work then try asking your web host for help but you may need leave index.php in your permalinks if you can’t resolve this.

    Thread Starter ayaztariq786

    (@ayaztariq786)

    tried every thing.

    but problem is solved by resting my plesk account.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Remove index.php from permalinks’ is closed to new replies.