Support » Plugin: PowerPress Podcasting plugin by Blubrry » Remove Image Attributes

  • OH MY GRAVY (OMG), this is beginning to get annoying. I never had this issue with categories before and regret ever removing them.

    I’m in the process of setting up category podcasts for submission to iTunes. Once accepted you send a request to put them all under one umbrella; in this case partyfavorz.com. Easy peasy.

    What’s changed since the last time I did this in 2015 is that WordPress is now forcing image attributes, most likely as a Google requirement. So my 3000×3000 kick-butt images I’ve created for each category are displaying as 952×952.

    When I go to validate each feed prior to submission; everything looks great except that iTunes is defaulting to my standard logo that I use for the main site because the attributes generated by WordPress override the actual image size that does not meet iTunes requirements. I’m a reasonably smart guy and can figure this out.

    I research the issue online and find a plethora of posts about this issue. The general consensus is to put this code:

    <?php
    /* Write your awesome functions below */
    
    function remove_img_attributes( $html ) {
    $html = preg_replace( '/(width|height)="\d*"\s/', "", $html );
    return $html;
    }
    add_filter( 'post_thumbnail_html', 'remove_img_attributes', 10 );
    add_filter( 'image_send_to_editor', 'remove_img_attributes', 10 );

    into your functions.php file. As with most newer themes, you have to do this in the child theme. No matter if I use my theme generated child theme or one created by the plugin Childify, it has never worked. Nevertheless, I tried.

    Sure enough, I switch to the Customizr Pro Child theme and add the code then re-upload one test image and it still doesn’t work. I delete the image, remove my caching plugin, clear my browser and then reboot my computer and do it again. Still doesn’t work.

    What to do? I thought I might upload the images to Google Sites and link them back that way but the same issue persists with those freaking attributes added to the images.

    I guess I’m not looking so smart after all. Any other suggestions for removing the images attributes upon uploading would be welcome.

Viewing 15 replies - 1 through 15 (of 20 total)
  • Oh wait, let me try adding them in Cloudfront. That may be my best option. I’ll report back shortly.

    Head in hands; I give up. Attributes still added even in my own paid controlled environment that I apparently have no control over.

    Really need to think outside of the box. I can’t be the only person having this issue.

    Plugin Author Angelo Mandato

    (@amandato)

    iTunes uses the <itunes:image> attribute in the feed, nothing in WordPress itself should be modifying that, only PowerPress. You may have some other plugin that is also trying to add podcasting to you site perhaps that is the problem.

    You mention you are using category podcasting. Are you using strict category podcasting in PowerPress? Did you also enable Podcast only feeds?

    Can you reply with the category feeds in question so we can take a look?

    Hey Angelo,

    I only started on the first category when I noticed the issue. WordPress actually does add the image attributes to files; especially when it’s 3000×3000 when they are uploaded. Here is an image for one of the categories that’s the required size Image. Once you inspect it, you’ll see the image attributes in the smaller size, which is because sites are supposed to be responsive. If you click on the image with the magnifying glass it will expand to full size and the attributes will change to 3000×3000.

    The problem is that when submitted to iTunes, they only read the initial attributes not the actual size, in which case they default to my logo for the main site. I had setup categories last year and this wasn’t an issue. Here is my logo Logo which has the same attributes added but iTunes has no issue accepting this one.

    I removed the one category I had setup because when I have the categories activated the link to iTunes subscribe is blank. If unchecked, it will load the main site in iTunes. Until I get this resolved, I’d rather folks didn’t get a blank field.

    Why is it when you chime in I figure out the issue? It’s like the gates of heaven just open up or something LOL.

    Here’s the problem: <Error>
    NoSuchBucket
    <Message>The specified bucket does not exist</Message>
    <BucketName>itunes-artwork</BucketName>
    <RequestId>D4BBB45B7DB2F34A</RequestId>
    <HostId>
    pspVwRxiLOrnrDoGuJVM5r1NjWpLvyvv31kBCQzcIAzBu6ZQ2DQYH0ZaxMho1lapxctdbh7dBU0=
    </HostId>
    </Error>

    I’ve been dealing with the SSL issue. All my podcasts are hosted on Amazon’s S3 bucket which is also https. I had been trying out Cloudfront for my CDN and decided I didn’t need it because site is already blazing fast. It’s apparently still stuck in the system for some previous loaded images.

    It all works but occasionally I get locked out when I’m working because it’s perceived by Google that the site is not safe due to conflicting certifications. This is my next issue to tackle because I haven’t been able to wrap my head around uploading my cert to Cloudfront to get it resolved.

    Anyway, if I upload a new image and delete the old one it still does it. I’ll try renaming the file to see if it’ll accept it but I’ve gotta head out. Will let you know but I think that should resolve this problem.

    Plugin Author Angelo Mandato

    (@amandato)

    @kjam, I would suggest asking one question per post, that way you get a clear answer. At the moment I’m not 100% I am answering your questions. I will try my best.

    You can use Amazon CloudFront with iTunes, we’ve done it for consultation clients for years, no issues.

    Some SSL certs are not accepted by iTunes, we have a page on that if you need that.

    If you upload your iTunes image within PowerPress Settings, PowerPress will check the image has the right attributes, image size, etc.. Please upload within PowerPress if you are having image issues.

    Thanks,
    Angelo

    Sorry for the confusion. That wasn’t intended to be another question. It’s an issue I already have on the table and it’s what’s affecting this particular issue.

    I will try as you suggest uploading from within the plugin as opposed to just providing the URL from my media library. If that doesn’t work, I’ll change the name.

    Thanks again.

    Plugin Author Angelo Mandato

    (@amandato)

    Okay great. Also the iTunes image can take 24-72 hours to update once you make the change in your feed. Another reason to use PowerPress is that we use a unique method to change the filename slightly every time you upload a new image that way it lets iTunes know there is a new image. If the URL does not change, it can take months before iTunes gets the updated image.

    Okay Angelo,

    I cleared up some headaches and started back to posting content on the site. Everyone’s happy, I’m happy and I’m never happy LOL.

    I thought I’d go back and dig into the categories issue.

    First, I wasn’t even aware of ‘Strict Categories’ and ‘Separate blog posts from podcast episodes’ options until you mentioned them. I’m guessing these are part of the update from the summer.

    I setup a bare-bones category that was a little more forum friendly without all the details yet.

    Compared to the last two I just tried to setup for the same issue persists (regardless of whether those two new options are selected or not).

    I am uploading a 3000×3000 original artwork for each category specific to the genre. I’ve done this before and had no issues. The problem I’m having is that the feed is perfect in all aspects and validates nicely BUT it’s pulling the 3000X3000 logo from the main feed instead of the one I just uploaded designed for that category.

    Here is the sample feed; keep in mind, the fields are not filled out yet; This was simply for testing purposes but it’s consistent with multiple setups I’ve tried.

    Diva Category Feed

    The image it’s pulling is Main Site Feed Logo

    The image that it should be (and the correct URL is listed after being saved) is Diva Category Feed

    Even the RSS field is pulling the main feed logo.

    I thought it was my caching plugin and deactivated it; cleared my browser; then rebooted my computer but still nothing worked. I tried saving with the various fix options you offer and/or clearing the PowerPress cache via Tools but neither worked.

    When I originally tried to set these up; ALL of my plugins were deactivated. I tried setting it up using the TwentySixteen Theme just now (because I know you’ll ask) and sadly, the problem presists.

    Like I said earlier, I’ve set these up before and had them listed in iTunes under the Party Favorz main umbrella. The whole process of setting the categories up and submitting it to iTunes is a piece of cake. But, this is definitely a new issue that I can replicate over and over (at least on my site).

    I’ve wasted half a day on this and am just going to move on and update my site structure in Search Console tomorrow so I can knock out the little things. If you need the other two feeds for testing; let me know and I’ll send them to you.

    If this is just a problem with me, then I wouldn’t waste too much time. It’s nice to have but not the end of the world.

    Fixed link, this is what’s in the feed for image:

    Main Site Logo Feed

    I submitted all 10 of my category feeds on Friday and was approved on Monday. Yesterday, I was approved for a provider page so now all of the categories are showing up under my main feed.

    As you can see, I’ve updated my main site feed with a new logo which floated through with no issues.

    The problem is definitely with the category feeds artwork. For whatever reason, it’s pulling the main feed artwork in and does not allow for new artwork specific to each category to be displayed, which is annoying on a provider page because it doesn’t separate the differences between the podcasts. They all look the same.

    I did notice that unlike changing anything in the main feed settings, every time you save a change in the category feed, it kicks you out and you have to go back in to finish up. I would expect the default behavior for the main feed settings to be the same as they are for category settings but it is not.

    In the greater scheme of things, this is a minor hiccup. But from a marketing and branding perspective this is a nightmare.

    Happy Thanksgiving!

    Plugin Author Angelo Mandato

    (@amandato)

    Can you reply with one of these problem category feeds so I can take a look?

    Happy Thanksgiving!

    https://partyfavorz.com/category/tributes/feed/

    I did this one for just now. Uploaded from within the program and it added a few extra numbers so the title would be different and it still doesn’t work. It’s showing the main feed logo.

    Angelo, could you provide me with the download link to the build prior to the update in July. I’m fairly confident that that will resolve this issue. Once done, I can update back to the current version. Please.

    Plugin Author Angelo Mandato

    (@amandato)

    Hello @kjam,

    Are you sure you have an issue? I look at your feed, this is the image: https://partyfavorz.com/wp-content/uploads/powerpress/2017-Logo-RSS-350.jpg (is this correct?) If this is not the correct URL to the image, please reply with the correct URL so I know what to be looking for.

    Your iTunes listing also has this image: https://itunes.apple.com/us/podcast/tribute-party-favorz-live/id1178259190 so that is working correctly.

    All previous versions are available here: https://wordpress.org/plugins/powerpress/developers/ Let me know which version going back fixes your issue if it does.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Remove Image Attributes’ is closed to new replies.