Support » Theme: Klopp » Remove header image from every page i create

  • Hi

    can someone please tell me how to stop the header from the homepage repeating on every other page on my site?

    Cheers

Viewing 5 replies - 16 through 20 (of 20 total)
  • CrouchingBruin

    (@crouchingbruin)

    Hi, Becky:

    Well, I see that you’ve copied in the CSS above, which is a good start (but, of course, change the value of the background-image to point to one of your own images).

    The problem with the extra space is the very first rule that you added:

    
    .site-header {
        height: 650px;
    }
    

    Change it so it looks like this:

    
    .home .site-header {
        height: 650px;
    }
    

    Second, add these two rules to the end, but first, add the right brace } that’s missing after the last rule. So change this:

    
    .home .site-branding {
        padding: 125px 0;
    

    To this:

    
    .home .site-branding {
        padding: 125px 0;
    }
    .home .site-title-wrapper {
        padding: 6% 1rem;
    }
    
    .site-title-wrapper {
        padding: 0;
    }
    
    beckyhoefs

    (@beckyhoefs)

    Oh this is wonderful! Thank you so much for your fast reply and your help!

    Hi CrouchingBruin,

    I too want the header image to display ONLY on the home page but not other pages.
    As you suggested above to follow the navigation:
    Appearance → Customize → Design & Layout → Custom CSS

    But, I dont have that, rather I see Appearance → Customize –> Additional CSS
    Do I need to do the coding here?

    I added the below but couldnt get rid of the header image from any of the pages.

    #masthead.site-header {
    background-image: none;
    min-height: 0;
    }
    #masthead .layer {
    background: #003;
    min-height: 0;
    }
    .site-branding {
    padding: 20px 0;

    You may check the website: MyAshvita.in

    Regards,
    Raja

    • This reply was modified 4 months, 3 weeks ago by  raja21be.

    @raja21be, this thread is on the Klopp support page, and the problem is that you are using a different theme (Moesia). The CSS for one theme will not necessarily work with another theme. That’s also the reason why you don’t see the Custom CSS option in the same place, the Klopp theme has its own Custom CSS option, but you should use the new WordPress Additional CSS option for Moesia. The next time you have a question about your theme, please post your question on the Moesia support page.

    Instead of the first rule, try adding these two rules instead:

    
    #masthead {
       height: 0 !important;
    }
    
    .home #masthead {
       height: 741px !important;
    }
    

    @crouchingbruin – Thank you so much for your response. I will try out the changes you suggested.
    It was my bad as I actually google’d my question and this forum showed up right up there.

Viewing 5 replies - 16 through 20 (of 20 total)
  • You must be logged in to reply to this topic.