Support » Plugin: Google Forms » Remove Google passwords text

  • Resolved fannaticall

    (@debrawhite)



    (1) At the end, just before the submit button, I’m seeing this text:

    Never submit passwords through Google Forms.

    Which has absolutely no relevance to the user. Any way to get rid of this pls?

    (2) paragraph breaks are showing in the google form in the text underneath section leads. But the beaks are lost on my site. Any ideas on how to resolve, pls?

    Many thanks

    http://wordpress.org/extend/plugins/wpgform/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Mike Walsh

    (@mpwalsh8)

    Google uses the CSS class “ss-secondary-text” for both the Help Text on questions and to wrap the “Never submit …” message. If you want to hide only the “Never submit …” message but display your Help Text, try adding the following CSS to your custom CSS:

    .ss-form-entry > .ss-secondary-text {
        display: none;
    }

    The paragraph breaks are hard to diagnose without seeing your form itself as a lot of times they are introduced by your theme. Can you post a URL?

    Many thanks! V quick! I have a developer working on this but he seems to have got stuck at these points.

    http://debra-white.com/client-pages/1815-2/

    I will try that code.

    I can get paragraph breaks by selecting Enable default WordPress Google Form CSS but then I get some other stuff I don’t want. I don’t really know enough html & css to understand this, but am giving it a try!

    Thanks again!

    Excellent. Thank you. That got rid of “Never submit …”

    Now I need to lose the legal stuff which as crept back in and also get some proper pararaphs.

    Thx!

    Plugin Author Mike Walsh

    (@mpwalsh8)

    You can make the whole legal block go away two ways:

    1. When you define the form, there is an option to set Legal to Off.
    2. Add the following CSS to your Custom CSS declaration:
      .ss-legal {
          display: none;
      }

    Hope that helps.

    Thanks!

    Legal was already off but the text came back anyway (!?!)

    This code has completely removed legal block (good!) but now the confirmation redirect function has completely stopped working!

    Thx for your help!

    Plus this option:

    Log WordPress Google Form Submissions?

    repeatedly de-selects itself.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    There is a Javascript error on your page somewhere. You can see it if you use something like Firefox’s web developer error console. I don’t think it is coming from my plugin because I don’t recognize the code I see. A Javascript error will prevent the redirect from working because it is done with Javascript when the DOM is ready which never happens when an error is encountered.

    Regarding the Log Form Submissions check box, I’ll have to look into that later today.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    The syntax error may be from WordPress Google Form after all. Looking at it in Chrome I see a different error than in Firefox. I will try and see what it causing the syntax error.

    For some reason the Validation Rules section of the jQuery script is incomplete. That is the source of the syntax error.

    Much appreciated.

    Following this I turned validation off, and the redirect is now working. It’s not immediate, and I can see the Google confirmation page, but then it flips to mine. This is good progress!

    Many thanks. I’ll keep watching for updates in case of progress with fixes for this and the submissions log, and won’t change any more settings in the meantime!

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I fixed this bug tonight and have made v0.50 available. More details can be found here.

    Plugin Author Mike Walsh

    (@mpwalsh8)

    I did some testing of the Log Form Responses checkbox and am unable to replicate what you are describing. Are you saving the state of the checkbox using the save button on Advanced Options tab or are you toggling between tabs and changing multiple settings and doing a save once? If you are doing the later, it won’t work. You need to set and save each page of options separately.

    Apologies for the delay in acknowledging. Got caught up with another project. Just installed update and all is fine. It is not redirecting straight to my thank you page, but it isn’t a big problem.

    Have another query about validation but will post again if necessary about that.

    Thanks!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Remove Google passwords text’ is closed to new replies.